<!doctype html>
<html prefix="og: http://ogp.me/ns#" prefix="og: http://ogp.me/ns# fb: http://ogp.me/ns/fb# ssabludowsky: http://ogp.me/ns/fb/ssabludowsky#" xml:lang="en-gb" lang="en-gb">
<head>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<base href="http://www.bayoubuzz.com/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney"/>
<meta http-equiv="content-type" content="text/html; charset=utf-8"/>
<meta name="keywords" content="donald trump, donald trump jr, trump jr, donald trump email, russian attorney, trump tower, donald trump email russian attorney, russian hacking"/>
<meta name="title" content="Smoke, Fire or Nothing Burger?  Donald Trump Jr. releases email chain about Russian attorney"/>
<meta name="author" content="Stephen Sabludowsky"/>
<meta name="description" content="Smoke,Fire or Nothing Burger?  Donald Trump Jr. releases email chain about Russian attorney"/>
<meta name="generator" content="Joomla! - Open Source Content Management"/>
<title>Smoke, Fire or Nothing Burger? Donald Trump Jr. releases email chain about Russian attorney</title>
<link href="http://www.bayoubuzz.com/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney" rel="canonical"/>
<link rel="stylesheet" href="/index.php?option=com_ajax&plugin=arktypography&format=json" type="text/css"/>
<link rel="stylesheet" href="/index.php?option=com_ajax&plugin=arkbootstrap&format=json" type="text/css"/>
<link rel="stylesheet" href="/media/system/css/modal.css" type="text/css"/>
<link rel="stylesheet" href="/components/com_k2/css/k2.css" type="text/css"/>
<link rel="stylesheet" href="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9/themes/base/jquery-ui.css" type="text/css"/>
<link rel="stylesheet" href="http://www.bayoubuzz.com/plugins/content/pdf_embed/assets/css/style.css" type="text/css"/>
<link rel="stylesheet" href="/plugins/system/rokbox/assets/styles/rokbox.css" type="text/css"/>
<link rel="stylesheet" href="/media/sourcecoast/css/sc_bootstrap.css" type="text/css"/>
<link rel="stylesheet" href="/media/sourcecoast/css/common.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/bootstrap.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/master-5bc6b4c60150337a2a5bbbc901fc3590.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/demo-5bc6b4c60150337a2a5bbbc901fc3590.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/mediaqueries.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/grid-flexbox-responsive.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/menu-dropdown-direction.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/thirdparty-k2-5bc6b4c60150337a2a5bbbc901fc3590.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/canvas.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css-compiled/menu.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/css/rt_tessellate-custom.css" type="text/css"/>
<link rel="stylesheet" href="http://www.bayoubuzz.com/media/editors/arkeditor/css/squeezebox.css" type="text/css"/>
<link rel="stylesheet" href="/templates/rt_tessellate/roksprocket/layouts/tabs/themes/default/tabs.css" type="text/css"/>
<style type="text/css">@font-face{font-family:"IcoMoon";font-style:normal;font-weight:normal;src:url("http://www.bayoubuzz.com/media/jui/fonts/IcoMoon.eot?#iefix") format("embedded-opentype"),url("http://www.bayoubuzz.com/media/jui/fonts/IcoMoon.woff") format("woff"),url("http://www.bayoubuzz.com/media/jui/fonts/IcoMoon.ttf") format("truetype"),url("http://www.bayoubuzz.com/media/jui/fonts/IcoMoon.svg#IcoMoon") format("svg");}#rt-logo{background:url(/images/rocket/logo-tiny-new.jpg) 50% 0 no-repeat!important;}#rt-logo{width:80px;height:30px;}</style>
<script src="/media/system/js/mootools-core.js" type="text/javascript"></script>
<script src="/media/system/js/core.js" type="text/javascript"></script>
<script src="/media/system/js/mootools-more.js" type="text/javascript"></script>
<script src="/media/system/js/modal.js" type="text/javascript"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js" type="text/javascript"></script>
<script src="/plugins/system/jqueryeasy/jquerynoconflict.js" type="text/javascript"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9/jquery-ui.min.js" type="text/javascript"></script>
<script src="/media/jui/js/jquery-migrate.min.js" type="text/javascript"></script>
<script src="/components/com_k2/js/k2.js?v2.6.9&amp;sitepath=/" type="text/javascript"></script>
<script src="/plugins/system/rokbox/assets/js/rokbox.js" type="text/javascript"></script>
<script src="/components/com_jfbconnect/includes/jfbconnect.js?v=6" type="text/javascript"></script>
<script src="/media/sourcecoast/js/jq-bootstrap-1.8.3.js" type="text/javascript"></script>
<script src="/templates/rt_tessellate/js/chart.js" type="text/javascript"></script>
<script src="/templates/rt_tessellate/js/fss.js" type="text/javascript"></script>
<script src="/templates/rt_tessellate/js/fss-defaults.js" type="text/javascript"></script>
<script src="/templates/rt_tessellate/js/fss-config.js" type="text/javascript"></script>
<script src="/libraries/gantry/js/gantry-totop.js" type="text/javascript"></script>
<script src="/libraries/gantry/js/browser-engines.js" type="text/javascript"></script>
<script src="/templates/rt_tessellate/js/rokmediaqueries.js" type="text/javascript"></script>
<script src="/modules/mod_roknavmenu/themes/default/js/rokmediaqueries.js" type="text/javascript"></script>
<script src="/modules/mod_roknavmenu/themes/default/js/sidemenu.js" type="text/javascript"></script>
<script src="http://www.bayoubuzz.com/media/editors/arkeditor/js/jquery.easing.min.js" type="text/javascript"></script>
<script src="http://www.bayoubuzz.com/media/editors/arkeditor/js/squeezebox.min.js" type="text/javascript"></script>
<script src="/components/com_roksprocket/assets/js/mootools-mobile.js" type="text/javascript"></script>
<script src="/components/com_roksprocket/assets/js/rokmediaqueries.js" type="text/javascript"></script>
<script src="/components/com_roksprocket/assets/js/roksprocket.js" type="text/javascript"></script>
<script src="/components/com_roksprocket/layouts/tabs/themes/default/tabs.js" type="text/javascript"></script>
<script type="text/javascript">

		jQuery(function($) {
			SqueezeBox.initialize({});
			SqueezeBox.assign($('a.modal').get(), {
				parse: 'rel'
			});
		});
		function jModalClose() {
			SqueezeBox.close();
		}if (typeof RokBoxSettings == 'undefined') RokBoxSettings = {pc: '100'};window.addEvent('domready', function(){
            this.RENDERER = 'canvas';
            if (typeof this.MESH != 'undefined'){
                this.MESH.ambient = '#08162A';
                this.MESH.diffuse = '#3068D3';
            }
            if (typeof this.LIGHT != 'undefined'){
                this.LIGHT.ambient = '#08162A';
                this.LIGHT.diffuse = '#3068D3';
            }
        });		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
		__gaTracker('create', 'UA-385892-2', 'auto');
		__gaTracker('send', 'pageview');
	jQuery(function($)
				{
					if($.fn.squeezeBox)
					{
						$( 'a.modal' ).squeezeBox({ parse: 'rel' });
			
						$( 'img.modal' ).each( function( i, el )
						{
							$(el).squeezeBox({
								handler: 'image',
								url: $( el ).attr( 'src' )
							});
						})
					}
					else if(typeof(SqueezeBox) !== 'undefined')
					{
						$( 'img.modal' ).each( function( i, el )
						{
							SqueezeBox.assign( el, 
							{
								handler: 'image',
								url: $( el ).attr( 'src' )
							});
						});
					}
					
					function jModalClose() 
					{
						if(typeof(SqueezeBox) == 'object')
							SqueezeBox.close();
						else
							ARK.squeezeBox.close();
					}
				
				});if (typeof RokSprocket == 'undefined') RokSprocket = {};
Object.merge(RokSprocket, {
	SiteURL: 'http://www.bayoubuzz.com/',
	CurrentURL: 'http://www.bayoubuzz.com/',
	AjaxURL: 'http://www.bayoubuzz.com/index.php?option=com_roksprocket&amp;task=ajax&amp;format=raw&amp;ItemId=1782'
});
window.addEvent('domready', function(){
		RokSprocket.instances.tabs = new RokSprocket.Tabs();
});
window.addEvent('domready', function(){
	RokSprocket.instances.tabs.attach(723, '{"autoplay":"1","delay":"3"}');
});
window.addEvent('load', function(){
   var overridden = false;
   if (!overridden && window.G5 && window.G5.offcanvas){
       var mod = document.getElement('[data-tabs="723"]');
       mod.addEvents({
           touchstart: function(){ window.G5.offcanvas.detach(); },
           touchend: function(){ window.G5.offcanvas.attach(); }
       });
       overridden = true;
   };
});

  </script>
<link href="http://feeds.feedburner.com/bayoubuzz/BnFN" rel="alternate" type="application/rss+xml" title="Latest Buzz"/>
<link href="http://feeds.feedburner.com/bayoubuzz/QPkg" rel="alternate" type="application/rss+xml" title="News"/>
<link href="http://feeds.feedburner.com/bayoubuzz/GTum" rel="alternate" type="application/rss+xml" title="Buzz"/>
<script type="text/javascript">jfbc.login.logout_facebook = false;
jfbc.base = 'http://www.bayoubuzz.com/';
jfbc.return_url = 'L2JiL2l0ZW0vMTA2MjY2NC1zbW9rZS1maXJlLW9yLW5vdGhpbmctYnVyZ2VyLWRvbmFsZC10cnVtcC1qci1yZWxlYXNlcy1lbWFpbC1jaGFpbi1hYm91dC1ydXNzaWFuLWF0dG9ybmV5';
jfbc.login.scope = 'email,publish_actions,user_location,user_website';
jfbc.login.show_modal = '1';
jfbc.login.use_popup = true;
jfbc.login.auto = '1';
jfbc.login.logged_in = false;
jfbc.token = 'd0e1298166aaa930b9644bf135c374b4';
jfbc.init();
</script>
<meta name="twitter:description" content="Do we have smoke,fire or nothing burger? Donald Trump Jr. releases email chain about Russian attorney. Did the Trump campaign get anything of value from the Russians? Based upon the emeil chain that Donald Trump Jr. has posted on twitter this morning, there is an issue. However, it is also..."/>
<meta property="og:description" content="Do we have smoke,fire or nothing burger? Donald Trump Jr. releases email chain about Russian attorney. Did the Trump campaign get anything of value from the Russians? Based upon the emeil chain that Donald Trump Jr. has posted on twitter this morning, there is an issue. However, it is also..."/>
<meta name="twitter:image" content="http://www.bayoubuzz.com/images/rocket/trump-smoke.jpg"/>
<meta property="og:image" content="http://www.bayoubuzz.com/images/rocket/trump-smoke.jpg"/>
<meta name="twitter:title" content="Smoke, Fire or Nothing Burger?  Donald Trump Jr. releases email chain about Russian attorney"/>
<meta property="og:title" content="Smoke, Fire or Nothing Burger?  Donald Trump Jr. releases email chain about Russian attorney"/>
<meta property="og:url" content="http://www.bayoubuzz.com/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney"/>
<meta name="twitter:card" content="summary"/>
<meta property="og:type" content="article"/>
<meta property="fb:app_id" content="144929591627"/>
<meta property="og:locale" content="en_gb"/>
<meta property="og:site_name" content="Bayoubuzz"/>
<link rel="stylesheet" href="/media/sourcecoast/css/jfbconnect.css" type="text/css"/>
<script async="async" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<body class="logo-type-custom logo-type-custom demostyle-type-preset4 headermode-type-animated headersurround-type-preset4 mainbody-overlay-light font-family-tessellate font-size-is-xlarge menu-type-splitmenu menu-dropdownmenu-position-header-b layout-mode-responsive col12 option-com-k2 menu-bb "> <script>
        window.twttr = (function (d,s,id) {
          var t, js, fjs = d.getElementsByTagName(s)[0];
          if (d.getElementById(id)) return; js=d.createElement(s); js.id=id;
          js.src="https://platform.twitter.com/widgets.js"; fjs.parentNode.insertBefore(js, fjs);
          return window.twttr || (t = { _e: [], ready: function(f){ t._e.push(f) } });
        }(document, "script", "twitter-wjs"));
        twttr.ready(function (twttr) {
            // Now bind our custom intent events
            twttr.events.bind('tweet', jfbc.social.twitter.tweet);
        });
        </script><div id="fb-root"></div>
<script type="text/javascript">
  
  window.fbAsyncInit = function() {
    FB.init({version: 'v2.3',appId: '144929591627', status: true, cookie: true, xfbml: true});
FB.Event.subscribe('comment.create', jfbc.social.facebook.comment.create);
FB.Event.subscribe('comment.remove', jfbc.social.facebook.comment.remove);
FB.Event.subscribe('edge.create', jfbc.social.facebook.like.create);
FB.Event.subscribe('edge.remove', jfbc.social.facebook.like.remove);
jfbc.social.googleAnalytics.trackFacebook();
FB.Event.subscribe('auth.authResponseChange', function(response) {jfbc.login.facebook_onlogin();});
  };
  (function(d, s, id){
     var js, fjs = d.getElementsByTagName(s)[0];
     if (d.getElementById(id)) {return;}
     js = d.createElement(s); js.id = id;
     js.src = "//connect.facebook.net/en_GB/sdk.js";
     fjs.parentNode.insertBefore(js, fjs);
   }(document, 'script', 'facebook-jssdk'));
</script>
<div id="rt-page-surround">
<header id="rt-header-surround">
<div id="rt-fss-container" class="rt-fss-container">
<div id="rt-fss-output" class="rt-fss-container"></div>
</div>
<div class="rt-container">
<div id="rt-header">
<div class="rt-flex-container">
<div class="rt-grid-5 rt-alpha">
<div class="rt-logo-block">
<a href="/" id="rt-logo"></a>
</div>
</div>
<div class="rt-grid-7 rt-omega">
<div class="menu-block">
<div class="gf-menu-device-container responsive-type-panel">
</div>
<div class="gf-menu-device-container responsive-type-panel"></div>
<ul class="gf-menu gf-splitmenu l1 top">
<li class="item21">
<a class="item" href="/">
<span class="menu-item-bg">
Home </span>
</a>
</li>
<li class="item1782 active last" id="current">
<a class="item" href="/bb">
<span class="menu-item-bg">
BB </span>
</a>
</li>
<li class="item82 parent">
<a class="item" href="/buzz">
<span class="menu-item-bg">
Buzz </span>
</a>
</li>
<li class="item758">
<a class="item" href="/rss">
<span class="menu-item-bg">
RSS </span>
</a>
</li>
<li class="item880">
<a class="item" href="/bayoubuzz-videos">
<span class="menu-item-bg">
Bayoubuzz videos </span>
</a>
</li>
<li class="item1509">
<a class="item" href="/subscribe">
<span class="menu-item-bg">
Newsletter </span>
</a>
</li>
<li class="item1788">
<a class="item" href="/jon-bel-edwards">
<span class="menu-item-bg">
John Bel Edwards </span>
</a>
</li>
<li class="item1789">
<a class="item" href="/louisiana-legislature">
<span class="menu-item-bg">
Louisiana legislature </span>
</a>
</li>
</ul> <div class="clear"></div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div>
</div>
<div id="rt-drawer">
<div class="rt-flex-container">
<div class="clear"></div>
</div>
</div>
<div id="rt-top">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
 
<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-0689976758489378" data-ad-slot="4004609422"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</header>
<section id="rt-mainbody-surround">
<div class="rt-container">
<div id="rt-main" class="mb9-sa3">
<div class="rt-flex-container">
<div class="rt-mainbody-wrapper rt-grid-9 ">
<div class="rt-component-block rt-block">
<div id="rt-mainbody">
<div class="component-content">
 
<span id="startOfPageId1062664"></span>
<div id="k2Container" class="itemView itemIsFeatured">
 
 
<div class="itemHeader">
 
<span class="itemDateCreated">
Tuesday, 11 July 2017 10:33 </span>
 
<h5 class="itemTitle">Smoke, Fire or Nothing Burger? Donald Trump Jr. releases email chain about Russian attorney</h5>
 
<span class="itemAuthor">
Written by&nbsp;
<a rel="author" href="/bb/itemlist/user/62-stephensabludowsky">Stephen Sabludowsky</a>
</span>
</div>
 
 
<div class="itemToolbar">
<ul>
 
<li>
<span class="itemTextResizerTitle">font size</span>
<a href="#" id="fontDecrease">
<span>decrease font size</span>
<img src="/components/com_k2/images/system/blank.gif" alt="decrease font size"/>
</a>
<a href="#" id="fontIncrease">
<span>increase font size</span>
<img src="/components/com_k2/images/system/blank.gif" alt="increase font size"/>
</a>
</li>
 
<li>
<a class="itemPrintLink" rel="nofollow" href="/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
<span>Print</span>
</a>
</li>
 
<li>
<a class="itemEmailLink" rel="nofollow" href="/component/mailto/?tmpl=component&amp;template=rt_tessellate&amp;link=80d8897388c39a2cad90b92b0fc7c5c3d0385126" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
<span>Email</span>
</a>
</li>
</ul>
<div class="clr"></div>
</div>
 
<div class="itemRatingBlock">
<span>Rate this item</span>
<div class="itemRatingForm">
<ul class="itemRatingList">
<li class="itemCurrentRating" id="itemCurrentRating1062664" style="width:0%;"></li>
<li><a href="#" data-id="1062664" title="1 star out of 5" class="one-star">1</a></li>
<li><a href="#" data-id="1062664" title="2 stars out of 5" class="two-stars">2</a></li>
<li><a href="#" data-id="1062664" title="3 stars out of 5" class="three-stars">3</a></li>
<li><a href="#" data-id="1062664" title="4 stars out of 5" class="four-stars">4</a></li>
<li><a href="#" data-id="1062664" title="5 stars out of 5" class="five-stars">5</a></li>
</ul>
<div id="itemRatingLog1062664" class="itemRatingLog">(0 votes)</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemBody">
 
<div style="position: relative; top:0px; left:0px; z-index: 99;" class="scsocialbuttons box_count"><div class="sourcecoast share twitter sc_twittershare"><a href="http://twitter.com/share" class="twitter-share-button" data-url="http://www.bayoubuzz.com/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney" data-count="vertical" data-dnt="false">Tweet</a></div><div class="sourcecoast plusone google sc_gplusone"><div class="g-plusone" data-annotation="bubble" data-size="tall" data-href="http://www.bayoubuzz.com/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney" data-recommendations="true" data-callback="plusone_callback"></div></div><div class="sourcecoast facebook like jfbclike"><div class="fb-like" data-href="http://www.bayoubuzz.com/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney" data-show-faces="true" data-share="true" data-layout="box_count" data-action="recommend" data-kid-directed-site="false"></div></div></div><div style="clear:both"></div>
 
 
<div class="itemIntroText">
<img src="/images/rocket/trump-smoke.jpg" alt=""/><p>Do we have smoke,fire or nothing burger?<p> Donald Trump Jr. releases email chain about Russian attorney. Did the Trump campaign get anything of value from the Russians?</p>
<p>Based upon the emeil chain that Donald Trump Jr. has posted on twitter this morning, there is an issue. &nbsp;However, it is also uncertain.</p> </div>
 
<div class="itemFullText">
<p>The email chain also shows that he knew that the the Russian government was the source, although it appears they might not have been. &nbsp;Also, it appears that the email is part of a continuing conversation he had either in person or some other means prior to this email.</p><p>
<div style="text-align:left;">
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7741304783035041" data-ad-type="text_image" data-color-border="FFFFFF" data-color-bg="FFFFFF" data-color-link="0088CC" data-color-text="555555" data-color-url="AAAAAA"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></p><blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Here is page 4 (which did not post due to space constraints). <a href="https://t.co/z1Xi4nr2gq">pic.twitter.com/z1Xi4nr2gq</a></p>&mdash; Donald Trump Jr. (@DonaldJTrumpJr) <a href="https://twitter.com/DonaldJTrumpJr/status/884789839522140166">July 11, 2017</a></blockquote>
<script async src="//platform.twitter.com/widgets.js" charset="utf-8"></script>
<p>It is appreciated that Trump Jr. has decided to get ahead of this story by posting the email chain to stop speculation. This is the type of activity that the Trump administration should have done from day one but instead, they have decided to play the same type of game that Hillary Clinton played in trying to delay and deny.</p>
</p>
</div>
<div class="clr"></div>
 
<div style="z-index: 98;" class="scsocialcomments"><div class="sourcecoast facebook comments jfbccomments"><div class="fb-comments" data-href="http://www.bayoubuzz.com/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney" data-width="450" data-num-posts="20" data-colorscheme="light" data-mobile="false" data-order-by="time"></div></div></div>
 
<div class="clr"></div>
</div>
 
<div class="itemSocialSharing">
 
<div class="itemTwitterButton">
<a href="https://twitter.com/share" class="twitter-share-button" data-count="horizontal" data-via="BayoubuzzSteve">
Tweet </a>
<script type="text/javascript" src="//platform.twitter.com/widgets.js"></script>
</div>
 
<div class="itemFacebookButton">
<div id="fb-root"></div>
<script type="text/javascript">
				(function(d, s, id) {
				  var js, fjs = d.getElementsByTagName(s)[0];
				  if (d.getElementById(id)) return;
				  js = d.createElement(s); js.id = id;
				  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";
				  fjs.parentNode.insertBefore(js, fjs);
				}(document, 'script', 'facebook-jssdk'));
			</script>
<div class="fb-like" data-send="false" data-width="200" data-show-faces="true"></div>
</div>
 
<div class="itemGooglePlusOneButton">
<g:plusone annotation="inline" width="120"></g:plusone>
<script type="text/javascript">
			  (function() {
			  	window.___gcfg = {lang: 'en'}; // Define button default language here
			    var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
			    po.src = 'https://apis.google.com/js/plusone.js';
			    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
			  })();
			</script>
</div>
<div class="clr"></div>
</div>
<div class="itemLinks">
 
<div class="itemCategory">
<span>Published in</span>
<a href="/bb">News</a>
</div>
<div class="clr"></div>
</div>
 
<div class="itemAuthorBlock">
<img class="itemAuthorAvatar" src="/media/k2/users/584.jpg" alt="Stephen Sabludowsky"/>
<div class="itemAuthorDetails">
<h5 class="itemAuthorName"><a rel="author" href="/bb/itemlist/user/62-stephensabludowsky">Stephen Sabludowsky</a></h5>
<p><p><a href="https://plus.google.com/u/0/+StephenSabludowsky/posts">https://plus.google.com/u/0/+StephenSabludowsky/posts</a></p>
<div class="g-person" data-href="//plus.google.com/113054450087898597578" data-rel="author">&nbsp;</div></p>
<span class="itemAuthorUrl">Website: <a rel="me" href="http://www.bayoubuzz.com/media/k2/users/584.jpg" target="_blank">www.bayoubuzz.com/media/k2/users/584.jpg</a></span>
<div class="clr"></div>
 
</div>
<div class="clr"></div>
</div>
 
<div class="itemAuthorLatest">
<h5>Latest from Stephen Sabludowsky</h5>
<ul>
<li class="even">
<a href="/bb/item/1062661-putin-rolls-trump-on-russian-interference-does-irreparable-damage-to-us-intelligence-credibility">Putin rolls Trump on Russian interference, does irreparable damage to US intelligence credibility</a>
</li>
<li class="odd">
<a href="/bb/item/1062653-president-trump-it-doesn-t-feel-like-independence-day">President Trump, It doesn't feel like Independence Day</a>
</li>
<li class="even">
<a href="/bb/item/1062647-birther-king-pimp-that-killed-acorn-slays-cnn-enemy-of-america">Birther King, Pimp that killed ACORN slays CNN, "Enemy of America"</a>
</li>
<li class="odd">
<a href="/bb/item/1062646-facebook-live-billy-tauzin-jim-brown-louisiana-political-institutions">FACEBOOK LIVE: Billy Tauzin, Jim Brown, Louisiana political institutions</a>
</li>
<li class="even">
<a href="/bb/item/1062639-trump-s-dangerous-doublespeak-of-russia-russia-russia">Trump's dangerous "DOUBLESPEAK" of Russia, Russia, Russia</a>
</li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>
 
<div class="itemNavigation">
<span class="itemNavigationTitle">More in this category:</span>
<a class="itemPrevious" href="/bb/item/1062663-stokes-drop-out-from-louisiana-s-treasurer-s-race-leaves-op-for-a-democrat">
&laquo; Stokes drop out from Louisiana's Treasurer's race leaves op for a Democrat? </a>
<a class="itemNext" href="/bb/item/1062665-walt-leger-won-t-run-for-new-orleans-mayor">
Walt Leger won't run for New Orleans Mayor &raquo;
</a>
</div>
 
 
 
<a name="itemCommentsAnchor" id="itemCommentsAnchor"></a>
<div class="itemComments">
<div>Login to post comments</div>
</div>
<div class="itemBackToTop">
<a class="k2Anchor" href="/bb/item/1062664-smoke-fire-or-nothing-burger-donald-trump-jr-releases-email-chain-about-russian-attorney#startOfPageId1062664">
back to top </a>
</div>
<div class="clr"></div>
</div>
 
 
</div>
</div>
</div>
<div id="rt-content-bottom">
<div class="rt-flex-container">
<div class="rt-grid-9 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div data-tabs="723">
<div class="sprocket-tabs layout-right animation-slideandfade">
<ul class="sprocket-tabs-nav">
<li data-tabs-navigation><span class="sprocket-tabs-inner">
<span class="sprocket-tabs-text">
A July 4th Fact of Facts: America is Land of Immigrants </span>
</span></li>
<li data-tabs-navigation><span class="sprocket-tabs-inner">
<span class="sprocket-tabs-text">
Poll: Trump strong on jobs, weak on tweets, viewed as reckless, thin-skinned, sexist </span>
</span></li>
<li data-tabs-navigation><span class="sprocket-tabs-inner">
<span class="sprocket-tabs-text">
President Trump, It doesn't feel like Independence Day </span>
</span></li>
<li data-tabs-navigation><span class="sprocket-tabs-inner">
<span class="sprocket-tabs-text">
YIPPIE! The naked truth about free speech, cherished especially on Independence Day </span>
</span></li>
</ul>
<div class="sprocket-tabs-panels">
<div class="sprocket-tabs-panel" data-tabs-panel>
<p><img src="/images/mass2.jpg" alt="mass2" style="float: left;"/>On July 4, 1778,<a href="http://www.history.com/topics/us-presidents/george-washington"> George Washington</a> doubled liquor rations for the soldiers quartered in Princeton, NJ, as a way to celebrate Independence Day. It&rsquo;s fitting, therefore, that the Fourth of July is America's top-selling beer holiday, <a href="http://www.beerinstitute.org/print/press-release/beer-sales-could-top-1-billion-again-this-july-fourth">according</a> to the Beer Institute. It estimated, in 2013, that sales of beer on the 4th could total $1 billion, doubtlessly higher today. &ldquo;In moderation,&rdquo; claims a CA brewery investor, Grover McKean, &ldquo;beer is tasty and healthy.&rdquo; Who could disagree?</p>
<p> <a href="/bb/item/1062654-a-july-4th-fact-of-facts-america-is-land-of-immigrants" class="readon"><span>Read More</span></a>
</div>
<div class="sprocket-tabs-panel" data-tabs-panel>
<p><img src="/images/joe-mika.jpg" alt="joe mika" style="float: left;"/>As Donald Trump faces the top world leaders this week, including a face-time with Vladimir Putin, and as his healthcare proposals face an uphill climb, his poll numbers for how the nation views him could be better.</p>
<p>According to a morning Consult/Politico poll released Wednesday morning, his tweets, including that against MSNBC's Mika Brzezinski, and his personality are not helping him, at all.</p>
<p></p>
<a href="/bb/item/1062656-poll-trump-strong-on-jobs-weak-on-tweets-viewed-as-reckless-thin-skinned-sexist" class="readon"><span>Read More</span></a>
</div>
<div class="sprocket-tabs-panel" data-tabs-panel>
<p><img src="/images/indy-day.jpg" alt="indy day" style="float: left;"/>II know the calendar says we are approaching the 4th of July, but, it just doesn&rsquo;t feel like Independence Day.</p>
<p>Perhaps it should.&nbsp; It&rsquo;s hot as heck.&nbsp; The airlines have been packed. The hot dogs are ready for grilling. &nbsp;The umps are saying, "play ball". The patriotic activities are scheduled. The fireworks are ready-for-blasting.&nbsp;</p>
<p>Yet, it just doesn&rsquo;t feel like independence day.</p>
<a href="/bb/item/1062653-president-trump-it-doesn-t-feel-like-independence-day" class="readon"><span>Read More</span></a>
</div>
<div class="sprocket-tabs-panel" data-tabs-panel>
<p><img src="/images/bill-rights2.jpg" alt="bill rights2" style="float: left;"/>To President Thomas Jefferson, July 4th celebrated more than the signing of the Declaration of Independence. He thought it was a link to the future. The message prominent colonists sent to King George III led to the Constitution and the Bill of Rights, the initial and most prominent feature of which is the First Amendment that guarantees free speech. It&rsquo;s part of the country&rsquo;s fundamental essence that each man and woman can say what they feel about government, or anything else, proving President Donald Trump needs some civics lessons.</p>
<p> <a href="/bb/item/1062655-yippie-the-naked-truth-about-free-speech-cherished-especially-on-independence-day" class="readon"><span>Read More</span></a>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="rt-sidebar-wrapper rt-grid-3 ">
<div class="rt-sidebar-block">
<div id="rt-sidebar-a">
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title">BB Menu</h2>
</div>
<div class="module-content submenu">
<div class="gf-menu-device-container responsive-type-panel">
</div> </div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<p><a href="http://www.latter-blum.com"><img src="/images/rocket/latter-blum2.gif" alt="latter-blum2" style="vertical-align: middle; display: block; margin-left: auto; margin-right: auto;"/></a></p></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<a href='https://streamwins.com/optin_box/2de0s2shxdxw6ld6' data-delay='0' data-exit='false'><img src="https://images.clickfunnels.com/uploads/image/image_file/7553890/full_Diem.jpg"></a><script src='https://www.clickfunnels.com/assets/cfpop.js' type='text/javascript'></script></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>TRUMP TALK </span></h2> </div>
<div class="module-content">
<div class="custom">
<iframe width="280" height="157" src="https://www.youtube.com/embed/f5muYquC1Hk" frameborder="0" allowfullscreen></iframe></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<script>
  (function() {
    var cx = '003463857494158402329:4uh44se2s_m';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = (document.location.protocol == 'https:' ? 'https:' : 'http:') +
        '//www.google.com/cse/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:search></gcse:search></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Dead Pelican</span></h2> </div>
<div class="module-content">
<div class="custom">
<p><a href="http://thedeadpelican.com"><img src="/images/stories/Optimized-DeadPelican2_1_1.jpg" alt="Optimized-DeadPelican2 1 1" style="display: block; margin-left: auto; margin-right: auto;"/></a></p></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
 
<script type="text/javascript"> 
(function(){ 
var cachebuster=Math.round(Math.random() * 100000); 
document.write('<scr' + 'ipt type="text/javascript" src="http://ads.adnxs.com/ttj?id=3646594&cb='+cachebuster+'"></scr'+'ipt>'); })(); 
</script>
 </div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</section>
<section id="rt-bodybottom-surround">
<div class="rt-container">
<div id="rt-mainbottom">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
</div>
<div class="clear"></div>
</div>
</div>
</div>
</section>
<footer id="rt-footer-surround">
<div class="rt-container">
<div id="rt-footer">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-social-buttons rt-block">
<div class="clear"></div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
 
<script src="//widget.manychat.com/90206201070.js" async="async">
</script></div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
<div id="rt-copyright">
<div class="rt-flex-container">
<div class="rt-grid-4 rt-alpha">
<div class="rt-block rt-branding">
<a href="http://www.bayoubuzz.com/" title="Bayoubuzz" class="rt-powered-by"></a>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Privacy</span></h2> </div>
<div class="module-content">
<div class="custom">
 
<div style="font-family: arial;"><a href="/Bayoubuzzprivacy.pdf"><strong>Privacy Policy</strong></a><span></span> </div></div>
</div>
</div>
</div>
</div>
<div class="rt-grid-4">
<div class="rt-copyright-content rt-block">
Designed by RocketTheme </div>
</div>
<div class="rt-grid-4 rt-omega">
<div class="clear"></div>
<div class="rt-block">
<a href="#" id="gantry-totop" rel="nofollow">Top</a>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</footer>
<div id="rt-debug">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<script src="//load.sumome.com/" data-sumo-site-id="2a18baf2d5e0074431d4a4599bef7c9a686717df312880c12be96ca0a1a4d641" async="async"></script></div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
<div id="jfbcLoginModal" class="sourcecoast modal" style="display:none"><div class="modal-body">You are now being logged in using your Facebook credentials</div></div><script type="text/javascript">
              (function() {
                var po = document.createElement('script'); po.type = 'text/javascript'; po.async = true;
                po.src = 'https://apis.google.com/js/plusone.js';
                var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(po, s);
              })();
            function plusone_callback(response) {
              jfbc.social.google.plusone(response);
            };
            </script></body>
</html>
