<!doctype html>
<html prefix="og: http://ogp.me/ns#" xml:lang="en-gb" lang="en-gb">
<head>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KTNXD4L');</script>

<meta name="viewport" content="width=device-width, initial-scale=1.0">
<base href="https://www.bayoubuzz.com/bb/donald-trump-news-today/donald-trump-news/item/1063228-mitt-romney-launches-utah-us-senate-bid-to-take-on-donald-trump" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="Donald Trump,Mitt Romney,US Senate" />
<meta name="title" content="Mitt Romney launches Utah US Senate bid to take on Donald Trump" />
<meta name="author" content="Jeff Crouere" />
<meta property="og:url" content="https://www.bayoubuzz.com/bb/donald-trump-news-today/donald-trump-news/item/1063228-mitt-romney-launches-utah-us-senate-bid-to-take-on-donald-trump" />
<meta property="og:title" content="Mitt Romney launches Utah US Senate bid to take on Donald Trump" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Mitt Romney launches Utah US Senate bid to take on Donald Trump for President, a position for which he has run twice" />
<meta name="description" content="Mitt Romney launches Utah US Senate bid to take on Donald Trump for President, a position for which he has run twice" />
<meta name="generator" content="Joomla! - Open Source Content Management" />
<title>Mitt Romney launches Utah US Senate bid to take on Donald Trump</title>
<link href="https://www.bayoubuzz.com/bb/donald-trump-news-today/donald-trump-news/item/1063228-mitt-romney-launches-utah-us-senate-bid-to-take-on-donald-trump" rel="canonical" />
<link href="https://www.bayoubuzz.com/bb/donald-trump-news-today/donald-trump-news/item/1063228-mitt-romney-launches-utah-us-senate-bid-to-take-on-donald-trump/amp" rel="amphtml" />
<link href="/templates/rt_tessellate/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_0.css" />
<link href="https://cdnjs.cloudflare.com/ajax/libs/magnific-popup.js/1.1.0/magnific-popup.min.css" rel="stylesheet" type="text/css" />
<link href="https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/css/simple-line-icons.min.css" rel="stylesheet" type="text/css" />
<link href="/components/com_k2/css/k2.css?v=2.8.0" rel="stylesheet" type="text/css" />
<link href="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9/themes/base/jquery-ui.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_1.css" />
<link href="/modules/mod_latestnewsenhanced/styles/common_styles-min.css" rel="stylesheet" type="text/css" />
<link href="https://www.bayoubuzz.com/plugins/content/pdf_embed/assets/css/style.css" rel="stylesheet" type="text/css" />
<link href="/plugins/system/rokbox/assets/styles/rokbox.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_2.css" />
<link href="https://www.bayoubuzz.com/media/editors/arkeditor/css/squeezebox.css" rel="stylesheet" type="text/css" />
<link href="https://www.bayoubuzz.com/modules/mod_ijoomla_adagency_zone/tmpl/mod_ijoomlazone.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_3.css" />
<script type="application/json" class="joomla-script-options new">{"csrf.token":"b761948983b31ba6c9d3f575e6ac7c4e","system.paths":{"root":"","base":""}}</script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/cbb65e30b4decc8926c8d0c58a3c1593_0.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js" type="text/javascript"></script>
<script src="/plugins/system/jqueryeasy/jquerynoconflict.js" type="text/javascript"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9/jquery-ui.min.js" type="text/javascript"></script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/cbb65e30b4decc8926c8d0c58a3c1593_1.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/magnific-popup.js/1.1.0/jquery.magnific-popup.min.js" type="text/javascript"></script>
<script src="/media/k2/assets/js/k2.frontend.js?v=2.8.0&amp;sitepath=/" type="text/javascript"></script>
<script src="/plugins/system/rokbox/assets/js/rokbox.js" type="text/javascript"></script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/cbb65e30b4decc8926c8d0c58a3c1593_2.js"></script>
<script src="/modules/mod_roknavmenu/themes/default/js/rokmediaqueries.js" type="text/javascript"></script>
<script src="/modules/mod_roknavmenu/themes/default/js/sidemenu.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/media/editors/arkeditor/js/jquery.easing.min.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/media/editors/arkeditor/js/squeezebox.min.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/modules/mod_ijoomla_adagency_zone/includes/helper.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/components/com_adagency/includes/js/domready.js" type="text/javascript"></script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/cbb65e30b4decc8926c8d0c58a3c1593_3.js"></script>
<script type="text/javascript">
if (typeof RokBoxSettings == 'undefined') RokBoxSettings = {pc: '100'};window.addEvent('domready', function(){
            this.RENDERER = 'canvas';
            if (typeof this.MESH != 'undefined'){
                this.MESH.ambient = '#08162A';
                this.MESH.diffuse = '#3068D3';
            }
            if (typeof this.LIGHT != 'undefined'){
                this.LIGHT.ambient = '#08162A';
                this.LIGHT.diffuse = '#3068D3';
            }
        });		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
		__gaTracker('create', '', 'auto');
		__gaTracker('send', 'pageview');
	(function()
				{
					if(typeof jQuery == 'undefined')
						return;
					
					jQuery(function($)
					{
						if($.fn.squeezeBox)
						{
							$( 'a.modal' ).squeezeBox({ parse: 'rel' });
				
							$( 'img.modal' ).each( function( i, el )
							{
								$(el).squeezeBox({
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							})
						}
						else if(typeof(SqueezeBox) !== 'undefined')
						{
							$( 'img.modal' ).each( function( i, el )
							{
								SqueezeBox.assign( el, 
								{
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							});
						}
						
						function jModalClose() 
						{
							if(typeof(SqueezeBox) == 'object')
								SqueezeBox.close();
							else
								ARK.squeezeBox.close();
						}
					
					});
				})();jQuery(function($){ $(".hasTooltip").tooltip({"html": true,"container": "body"}); });
	</script>
<link href="http://feeds.feedburner.com/bayoubuzz/BnFN" rel="alternate" type="application/rss+xml" title="Latest Buzz" />
<link href="http://feeds.feedburner.com/bayoubuzz/QPkg" rel="alternate" type="application/rss+xml" title="News" />
<link href="http://feeds.feedburner.com/bayoubuzz/GTum" rel="alternate" type="application/rss+xml" title="Buzz" />
<link href="http://feeds.feedburner.com/TrumpArticles" rel="alternate" type="application/rss+xml" title="Trump articles" />
<link href="http://feeds.feedburner.com//KGuc" rel="alternate" type="application/rss+xml" title="Louisiana news" />
<link href="http://feeds.feedburner.com/DonaldTrumpLatestNews" rel="alternate" type="application/atom+xml" title="Donald Trump Latest News" />
<link href="http://feeds.feedburner.com/bayoubuzz/oxlh" rel="alternate" type="application/atom+xml" title="New Orleans News" />
<link href="http://feeds.feedburner.com/StateOfLouisiana" rel="alternate" type="application/atom+xml" title="State of Louisiana" />

<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "WebSite",
                "url": "https://www.bayoubuzz.com",
                "potentialAction": {
                    "@type": "SearchAction",
                    "target": "https://www.bayoubuzz.com/index.php?option=com_search&searchphrase=all&searchword={search_term}",
                    "query-input": "required name=search_term"
                }
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "Organization",
                "url": "https://www.bayoubuzz.com",
                "logo": "https://www.bayoubuzz.com/images/logo-cropped.png"
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "Organization",
                "name": "Bayoubuzz",
                "url": "https://www.bayoubuzz.com",
                "sameAs": [
                  "https://www.facebook.com/Bayoubuzz/",
"https://twitter.com/BayoubuzzSteve",
"https://plus.google.com/+StephenSabludowsky",
"https://www.youtube.com/user/bayoubuzz",
"https://www.linkedin.com/in/steve-sabludowsky-631678/"
                ]
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "BreadcrumbList",
                "itemListElement": [{
                    "@type": "ListItem",
                    "position": 1,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/",
                        "name": "Home"
                    }
                },{
                    "@type": "ListItem",
                    "position": 2,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb",
                        "name": "BB"
                    }
                },{
                    "@type": "ListItem",
                    "position": 3,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/donald-trump-news-today/itemlist",
                        "name": "Donald Trump News Today"
                    }
                },{
                    "@type": "ListItem",
                    "position": 4,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/donald-trump-news-today/donald-trump-news",
                        "name": "Donald Trump News"
                    }
                },{
                    "@type": "ListItem",
                    "position": 5,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/donald-trump-news-today/donald-trump-news/item/1063228-mitt-romney-launches-utah-us-senate-bid-to-take-on-donald-trump",
                        "name": "Mitt Romney launches Utah US Senate bid to take on Donald Trump"
                    }
                }]
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org/",
                "@type": "Article",
                "mainEntityOfPage": {
                    "@type": "WebPage",
                    "@id": "https://www.bayoubuzz.com/bb/donald-trump-news-today/donald-trump-news/item/1063228-mitt-romney-launches-utah-us-senate-bid-to-take-on-donald-trump"
                },
                "headline": "Mitt Romney launches Utah US Senate bid to take on Donald Trump for President",
                "description": "Mitt Romney launches Utah US Senate bid to take on Donald Trump for President, a position for which he has run twice",
                "image": {
                    "@type": "ImageObject",
                    "url": "https://www.bayoubuzz.com/",
                    "height": 800,
                    "width": 800
                },
                "author": {
                    "@type": "Person",
                    "name": "Jeff Crouere"
                },
                "publisher": {
                    "@type": "Organization",
                    "name": "Bayoubuzz",
                    "logo": {
                        "@type": "ImageObject",
                        "url": "https://www.bayoubuzz.com/images/logo-cropped.png",
                        "width": 600,
                        "height": 60
                    }
                },
                "datePublished" : "2018-02-16T19:27:55-06:00",
                "dateCreated" : "2018-02-16T19:27:55-06:00",
                "dateModified": "-001-11-30T00:00:00-06:00"
            }
            </script>

</head>
<body class="logo-type-custom logo-type-custom demostyle-type-preset4 headermode-type-animated headersurround-type-preset4 mainbody-overlay-light font-family-tessellate font-size-is-xlarge menu-type-dropdownmenu menu-dropdownmenu-position-header-b layout-mode-responsive col12 option-com-k2 menu-donald-trump-news ">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KTNXD4L"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<div id="rt-page-surround">
<header id="rt-header-surround">
<div id="rt-fss-container" class="rt-fss-container">
<div id="rt-fss-output" class="rt-fss-container"></div>
</div>
<div class="rt-container">
<div id="rt-header">
<div class="rt-flex-container">
<div class="rt-grid-5 rt-alpha">
<div class="rt-logo-block">
<a href="/" id="rt-logo"></a>
</div>
</div>
<div class="rt-grid-7 rt-omega">
<div class="menu-block">
<div class="gf-menu-device-container responsive-type-panel">
</div>
<ul class="gf-menu l1 ">
<li class="item21 ">
<a class="item" href="/">
<span class="menu-item-bg">
Home </span>
</a>
</li>
<li class="item1782 parent active rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb">
<span class="menu-item-bg">
BB </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item1821 parent active rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/donald-trump-news-today">
<span class="menu-item-bg">
Donald Trump News Today </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1827 active last ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-news">
<span class="menu-item-bg">
Donald Trump News </span>
</a>
</li>
<li class="item1828 ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-news-tweets">
<span class="menu-item-bg">
Donald Trump news tweets </span>
</a>
</li>
<li class="item1933 ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-tags">
<span class="menu-item-bg">
Donald Trump Tags </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1788 ">
<a class="item" href="/bb/jon-bel-edwards">
<span class="menu-item-bg">
John Bel Edwards </span>
</a>
</li>
<li class="item1823 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/new-orleans-louisiana">
<span class="menu-item-bg">
New Orleans Louisiana </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1829 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections">
<span class="menu-item-bg">
New Orleans Elections </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l4">
<li class="item1866 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/michael-bagneris">
<span class="menu-item-bg">
Michael Bagneris </span>
</a>
</li>
<li class="item1867 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/latoya-cantrell">
<span class="menu-item-bg">
LaToya Cantrell </span>
</a>
</li>
<li class="item1868 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/desiree-charbonnet">
<span class="menu-item-bg">
Desiree Charbonnet </span>
</a>
</li>
<li class="item1869 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/troy-henry">
<span class="menu-item-bg">
Troy Henry </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1830 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections-twitter">
<span class="menu-item-bg">
New Orleans elections twitter </span>
</a>
</li>
<li class="item1831 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-news">
<span class="menu-item-bg">
New Orleans News </span>
</a>
</li>
<li class="item1934 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-louisiana-tag">
<span class="menu-item-bg">
New Orleans, Louisiana, Tag </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1824 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/state-of-louisiana">
<span class="menu-item-bg">
State of Louisiana </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1832 ">
<a class="item" href="/bb/state-of-louisiana/louisiana-legislature">
<span class="menu-item-bg">
Louisiana Legislature and Legislation </span>
</a>
</li>
<li class="item1833 ">
<a class="item" href="/bb/state-of-louisiana/louisiana-elections">
<span class="menu-item-bg">
Louisiana elections </span>
</a>
</li>
<li class="item1935 ">
<a class="item" href="/bb/state-of-louisiana/louisiana-tags-louisiana-news">
<span class="menu-item-bg">
Louisiana Tags, Louisiana news </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1978 ">
<a class="item" href="/bb/events">
<span class="menu-item-bg">
Events </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item82 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/buzz">
<span class="menu-item-bg">
Buzz </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
</div>
</li>
<li class="item758 ">
<a class="item" href="/rss">
<span class="menu-item-bg">
RSS </span>
</a>
</li>
<li class="item880 ">
<a class="item" href="/bayoubuzz-videos">
<span class="menu-item-bg">
Bayoubuzz videos </span>
</a>
</li>
<li class="item1509 ">
<a class="item" href="/subscribe">
<span class="menu-item-bg">
Newsletter </span>
</a>
</li>
<li class="item1838 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/issues">
<span class="menu-item-bg">
Issues </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item1836 ">
<a class="item" href="/issues/confederate-monuments">
<span class="menu-item-bg">
Confederate monuments </span>
</a>
</li>
<li class="item1835 ">
<a class="item" href="/issues/john-bel-edwards">
<span class="menu-item-bg">
John Bel Edwards </span>
</a>
</li>
<li class="item1826 ">
<a class="item" href="/issues/new-orleans">
<span class="menu-item-bg">
New Orleans </span>
</a>
</li>
<li class="item1834 ">
<a class="item" href="/issues/mitch-landrieu">
<span class="menu-item-bg">
Mitch Landrieu </span>
</a>
</li>
<li class="item1789 ">
<a class="item" href="/issues/louisiana-legislature">
<span class="menu-item-bg">
Louisiana legislature </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1840 ">
<a class="item" href="/authors">
<span class="menu-item-bg">
Authors </span>
</a>
</li>
<li class="item1865 grouped ">
<a class="item" href="/forums">
<span class="menu-item-bg">
 Forums </span>
</a>
</li>
<li class="item1930 ">
<a class="item" href="/tag">
<span class="menu-item-bg">
Tag </span>
</a>
</li>
<li class="item1942 ">
<a class="item" href="/feeds">
<span class="menu-item-bg">
Feeds </span>
</a>
</li>
</ul> <div class="clear"></div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div>
</div>
<div id="rt-drawer">
<div class="rt-flex-container">
<div class="clear"></div>
</div>
</div>
<div id="rt-top">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-0689976758489378" data-ad-slot="4004609422"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
<div id="rt-breadcrumbs">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<ul class="breadcrumb">
<li>
You are here: &#160;
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/" class="pathway"><span>Home</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="1">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb" class="pathway"><span>BB</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="2">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb/donald-trump-news-today/itemlist" class="pathway"><span>Donald Trump News Today</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="3">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb/donald-trump-news-today/donald-trump-news" class="pathway"><span>Donald Trump News</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="4">
</li>
<li itemscope itemtype="https://schema.org/ListItem" class="active">
<span>
Mitt Romney launches Utah US Senate bid to take on Donald Trump </span>
<meta content="5">
</li>
</ul>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</header>
<section id="rt-mainbody-surround">
<div class="rt-container">
<div id="rt-main" class="mb9-sa3">
<div class="rt-flex-container">
<div class="rt-mainbody-wrapper rt-grid-9 ">
<div class="rt-component-block rt-block">
<div id="rt-mainbody">
<div class="component-content">

<span id="startOfPageId1063228"></span>
<div id="k2Container" class="itemView">


<div class="itemHeader">

<span class="itemDateCreated">
Friday, 16 February 2018 13:27	</span>

<h1 class="itemTitle">
Mitt Romney launches Utah US Senate bid to take on Donald Trump
</h1>

<span class="itemAuthor">
Written by <a rel="author" href="/issues/itemlist/user/946-jeffcrouere">Jeff Crouere</a>
</span>
</div>


<div class="itemToolbar">
<ul>

<li>
<span class="itemTextResizerTitle">font size</span>
<a href="#" id="fontDecrease">
<span>decrease font size</span>
</a>
<a href="#" id="fontIncrease">
<span>increase font size</span>
</a>
</li>

<li>
<a class="itemPrintLink" rel="nofollow" href="/bb/donald-trump-news-today/donald-trump-news/item/1063228-mitt-romney-launches-utah-us-senate-bid-to-take-on-donald-trump?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
<span>Print</span>
</a>
</li>

<li>
<a class="itemEmailLink" rel="nofollow" href="/component/mailto/?tmpl=component&amp;template=rt_tessellate&amp;link=fcb28af938da8abcbf073af95fd63aa2cff5e651" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
<span>Email</span>
</a>
</li>
</ul>
<div class="clr"></div>
</div>

<div class="itemRatingBlock">
<span>Rate this item</span>
<div class="itemRatingForm">
<ul class="itemRatingList">
<li class="itemCurrentRating" id="itemCurrentRating1063228" style="width:0%;"></li>
<li><a href="#" data-id="1063228" title="1 star out of 5" class="one-star">1</a></li>
<li><a href="#" data-id="1063228" title="2 stars out of 5" class="two-stars">2</a></li>
<li><a href="#" data-id="1063228" title="3 stars out of 5" class="three-stars">3</a></li>
<li><a href="#" data-id="1063228" title="4 stars out of 5" class="four-stars">4</a></li>
<li><a href="#" data-id="1063228" title="5 stars out of 5" class="five-stars">5</a></li>
</ul>
<div id="itemRatingLog1063228" class="itemRatingLog">(0 votes)</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemBody">



<div class="itemIntroText">
<script async="async" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<p><img src="/images/comprofiler/mitt-don2.jpg" alt="mitt don2" style="float: left;" />In 1968, Michigan Governor George Romney failed in his campaign for the Republican presidential nomination. This presidential aspiration was shared by his son, Mitt Romney, who attempted to win the presidency four decades later. In 2008, Romney lost the GOP presidential primary battle to U.S. Senator John McCain (R-AZ), who was subsequently destroyed by Barack Obama in the general election.</p>
</div>

<div class="itemFullText">
<p>&nbsp;</p>
<p>Four years later, Romney ran again and won the Republican presidential nomination, but lost the general election to Obama, the incumbent. In that campaign, Romney was in a prime position to win after a strong first debate performance. Inexplicably, his campaign turned soft, he lost the final two debates and was handily defeated by Obama. As President Donald Trump noted in 2016, Romney “choked like a dog.”</p>
<p>Ever since that defeat, Romney has not faded away, but stayed in the forefront of national politics. In 2016, he viciously attacked Donald Trump and tried to prevent him from winning the presidency. He called Trump a “fraud,” and a “phony,” and supported the efforts of long-shot Republican candidate Evan McMullen to disrupt the election. In essence, an allegedly faithful Republican Party supporter Mitt Romney was helping liberal Democrat Hillary Clinton, who was the only candidate that benefitted from the attacks on Trump.</p>

<div id="lnee_739" class="lnee newslist vertical">
<ul class="latestnews-items">
<li class="latestnews-item id-1063226 catid-376">
<div class="news odd head_left">
<div class="innernews">
<div class="newshead picturetype">
<div class="picture">
<div class="innerpicture">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063226-temporary-clearances-problem-makes-trump-administration-a-reckless-security-risk" class="hasTooltip" title="Temporary clearances problem makes Trump administration a reckless security risk"> <img alt="Temporary clearances problem makes Trump administration a reckless security risk" src="/images/rocket/thumbnails/lnee/thumb_739_1063226.jpg" /> </a>
</div>
</div>
</div>
<div class="newsinfo">
<h4 class="newstitle">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063226-temporary-clearances-problem-makes-trump-administration-a-reckless-security-risk" class="hasTooltip" title="Temporary clearances problem makes Trump administration a reckless security risk"> <span>Temporary clearances problem makes Trump administration a reckless security risk</span>
</a>
</h4>
<div class="newsintro">
Post Rob Porter discovery shows temporary clearances problem makes Donald Trump administration a reckless security risk--Donald Trump News Today, security clearances </div>
</div>
</div>
</div>
</li>
<li class="latestnews-item id-1063224 catid-376">
<div class="news even head_left">
<div class="innernews">
<div class="newshead picturetype">
<div class="picture">
<div class="innerpicture">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063224-key-to-trump-s-infrastructure-plan-is-overcoming-roadblocks" class="hasTooltip" title="Key to Trump's infrastructure plan is overcoming roadblocks"> <img alt="Key to Trump's infrastructure plan is overcoming roadblocks" src="/images/rocket/thumbnails/lnee/thumb_739_1063224.jpg" /> </a>
</div>
</div>
</div>
<div class="newsinfo">
<h4 class="newstitle">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063224-key-to-trump-s-infrastructure-plan-is-overcoming-roadblocks" class="hasTooltip" title="Key to Trump's infrastructure plan is overcoming roadblocks"> <span>Key to Trump's infrastructure plan is overcoming roadblocks</span>
</a>
</h4>
<div class="newsintro">
Key to President Donald Trump's infrastructure plan is overcoming roadblocks--Donald Trump, infrastructure plan, Donald Trump news today </div>
</div>
</div>
</div>
</li>
</ul>
</div>

<p>With the upcoming retirement of U.S. Senator Orrin Hatch (R-UT), Romney has now officially announced his candidacy for the fall election. Romney is the overwhelming favorite to replace Hatch and become the preferred Trump opponent of the establishment wing of the Republican Party.</p>
<p>It did not take long for Senate candidate Romney to start his attacks on the President. In his announcement, Romney claimed that “Utah welcomes legal immigrants from around the world, Washington sends immigrants a message of exclusion.” Of course, this is a ludicrous charge as our country has been very hospitable to millions of legal immigrants.</p>
<p>During the Reagan administration, three million illegal immigrants were granted amnesty. Today, possibly 20 million illegal immigrants are in the country and President Trump is facing plenty of opposition to maintain his commitment to the American people to build a border wall. Polls show that Americans are supportive of legal immigrants but want border security and support action to stem the flow of illegal immigrants. Romney’s talking points have nothing to do with reality, but it is just his latest attempt to disparage President Trump.</p><p>
<div class="eliadunit" style="text-align:left;">

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-0689976758489378" data-ad-slot="5499311424" data-ad-type="text_image" data-color-border="FFFFFF" data-color-bg="FFFFFF" data-color-link="0088CC" data-color-text="555555" data-color-url="AAAAAA"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div class="eliadunit"></p>
<p>Ever since Donald Trump became President, Romney has looked for opportunities to criticize the President. He blasted the President’s response to the protests in Charlottesville, VA and the comments he supposedly made about Haiti and African countries while meeting with Senators to discuss immigration legislation.</p>
<p>Romney is a pure opportunist, which is why he is running for Senate in a state that he has only lived in for five years. Romney was born in Michigan and was elected as Governor of Massachusetts. According to Utah Republican Party Chairman Rob Anderson, Romney is “keeping out candidates that I think would be a better fit for Utah.” In an interview with the&nbsp;Salt Lake City Tribune, Anderson asserted that Romney “doesn’t live here, his kids weren’t born here, he doesn’t shop here.”</p>
<p>Even though he later apologized for his comments, Anderson was clearly telling the truth. The question is whether any Utah Republican will have the guts and financial backing to challenge Romney, who not only is the prohibitive favorite but also shares the same Mormon faith as 60% of Utah residents.</p>
<p>Notwithstanding a political miracle, Mitt Romney will become the next U.S. Senator from Utah. Once elected, he will abandon his supposed concern for the people of Utah and turn his attention toward criticizing the President with the ultimate goal of challenging him for the 2020 GOP presidential nomination.</p>
<p>Like his father, Mitt Romney has a burning desire to become President. This has not dissipated and will only become more intense when he is elected to “the most exclusive club in the world.” History has shown that the United States Senate is a launching pad for the White House. It has been quite useful for many Presidents, including the last politician to beat Mitt Romney in an election, Barack Obama.&nbsp;&nbsp;&nbsp;</p>

<div class="custom">
<P><h2 class="fb-share-button" data-href="https://developers.facebook.com/docs/plugins/" data-layout="button_count" data-size="large" data-mobile-iframe="true"><a href="https://www.facebook.com/sharer/sharer.php?u=https%3A%2F%2Fdevelopers.facebook.com%2Fdocs%2Fplugins%2F&amp;src=sdkpreparse" target="_blank" rel="noopener noreferrer" class="fb-xfbml-parse-ignore">Share</a></h2>
<h2><a href="https://twitter.com/share" class="twitter-share-button" data-size="large" data-show-count="false">Tweet</a></h2>
</div>

<p>Jeff Crouere is a native New Orleanian and his award winning program, “Ringside Politics,” airs locally at&nbsp;7:30 p.m.&nbsp;Fridays and at&nbsp;10:00 p.m.&nbsp;Sundays on PBS affiliate WLAE-TV, Channel 32, and from&nbsp;7-11 a.m.&nbsp;weekdays on WGSO 990-AM &amp;&nbsp;<a href="http://www.wgso.com/" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://www.wgso.com/&amp;source=gmail&amp;ust=1518895653914000&amp;usg=AFQjCNGwVrgEWb3zuoCxYGpQtIChGNjAGA">www.Wgso.com</a>. He is a political columnist, the author of&nbsp;America's Last Chance&nbsp;and provides regular commentaries on the Jeff Crouere YouTube channel and on&nbsp;<a href="http://www.ringsidepolitics.com/" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://www.ringsidepolitics.com/&amp;source=gmail&amp;ust=1518895653914000&amp;usg=AFQjCNHk5VriUJBrOAdPLDpxZ3gWooAzjQ">www.JeffCrouere.com</a>. For more information, email him at&nbsp;<span id="cloak0615ca9b83d38c37ab07381f3ca80975">This email address is being protected from spambots. You need JavaScript enabled to view it.</span><script type='text/javascript'>
				document.getElementById('cloak0615ca9b83d38c37ab07381f3ca80975').innerHTML = '';
				var prefix = '&#109;a' + 'i&#108;' + '&#116;o';
				var path = 'hr' + 'ef' + '=';
				var addy0615ca9b83d38c37ab07381f3ca80975 = 'j&#101;ff' + '&#64;';
				addy0615ca9b83d38c37ab07381f3ca80975 = addy0615ca9b83d38c37ab07381f3ca80975 + 'r&#105;ngs&#105;d&#101;p&#111;l&#105;t&#105;cs' + '&#46;' + 'c&#111;m';
				var addy_text0615ca9b83d38c37ab07381f3ca80975 = 'j&#101;ff' + '&#64;' + 'j&#101;ffcr&#111;&#117;&#101;r&#101;' + '&#46;' + 'c&#111;m';document.getElementById('cloak0615ca9b83d38c37ab07381f3ca80975').innerHTML += '<a ' + path + '\'' + prefix + ':' + addy0615ca9b83d38c37ab07381f3ca80975 + '\'>'+addy_text0615ca9b83d38c37ab07381f3ca80975+'<\/a>';
		</script></p>
<p>&nbsp;</p>
</div>
<div class="clr"></div>
<div class="itemContentFooter">

<span class="itemHits">
Read <b>78</b> times </span>
<div class="clr"></div>
</div>


<div class="clr"></div>
</div>

<div class="itemSocialSharing">

<div class="itemTwitterButton">
<a href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="BayoubuzzSteve">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<div class="itemFacebookButton">
<div id="fb-root"></div>
<script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)) return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script>
<div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
</div>

<div class="itemGooglePlusOneButton">
<div class="g-plusone" data-size="medium"></div>
<script>window.___gcfg={lang:'en-GB'};(function(){var po=document.createElement('script');po.type='text/javascript';po.async=true;po.src='https://apis.google.com/js/platform.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(po,s);})();</script>
</div>
<div class="clr"></div>
</div>
<div class="itemLinks">

<div class="itemCategory">
<span>Published in</span>
<a href="/bb/donald-trump-news-today/donald-trump-news">Donald Trump news</a>
</div>

<div class="itemTagsBlock">
<span>Tagged under</span>
<ul class="itemTags">
<li><a href="/issues/itemlist/tag/Donald%20Trump">Donald Trump</a></li>
<li><a href="/issues/itemlist/tag/Mitt%20Romney">Mitt Romney</a></li>
<li><a href="/issues/itemlist/tag/US%20Senate">US Senate</a></li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorBlock">
<img class="itemAuthorAvatar" src="/media/k2/users/7.jpg" alt="Jeff Crouere" />
<div class="itemAuthorDetails">
<h3 class="itemAuthorName">
<a rel="author" href="/issues/itemlist/user/946-jeffcrouere">Jeff Crouere</a>
</h3>
<p><p><strong><span style="font-family: arial,helvetica,sans-serif;"><span style="font-size: 12pt;"><span style="color: #0000ff; font-size: 10pt;"><span style="font-size: small;">Jeff&nbsp;Crouere&nbsp;is a native New Orleanian and his award winning program, Ringside Politics,” airs locally at&nbsp;7:30 p.m.&nbsp;Fridays and at&nbsp;10:00 p.m.&nbsp;Sundays on PBS affiliate WLAE-TV, Channel 32, and from&nbsp;7-11 a.m.weekdays on WGSO 990-AM &amp;&nbsp;<a href="http://www.wgso.com/" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://www.wgso.com/&amp;source=gmail&amp;ust=1507741094233000&amp;usg=AFQjCNEWxG_tZVsmojUm0mvUsw2kNnZ0Mg">www.Wgso.com</a>. He is a political columnist, the author of&nbsp;America's Last Chance&nbsp;and provides regular commentaries on the Jeff&nbsp;Crouere&nbsp;YouTube channel and on&nbsp;<a href="http://www.ringsidepolitics.com/" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://www.ringsidepolitics.com/&amp;source=gmail&amp;ust=1507741094233000&amp;usg=AFQjCNGqqUd8FuLWJJrMyNlaQFkPhJEE4Q">www.JeffCrouere.com</a>. For more information, email him at&nbsp;<a href="/cdn-cgi/l/email-protection#84eee1e2e2c4f6edeae3f7ede0e1f4ebe8edf0ede7f7aae7ebe9" target="_blank" rel="noopener noreferrer"><span class="__cf_email__" data-cfemail="9ef4fbf8f8def4fbf8f8fdecf1ebfbecfbb0fdf1f3">[email&#160;protected]</span></a></span></span></span></span></strong></p>
<p><strong><a href="https://plus.google.com/u/0/b/108092933627549646035/108092933627549646035/about">Visit Bayoubuzz's Google Page</a></strong></p>
<div class="R3" style="display: table-row; color: #404040; font-family: Roboto, arial, sans-serif; font-size: 13px;">
<div class="vSa d-k-l" style="position: relative; display: table-cell; color: #888888; font-size: 15px; padding: 10px 0px; text-align: right; width: 94px;"><strong>Home</strong></div>
<div class="wSa d-k-l" style="position: relative; display: table-cell; padding: 10px 23px 10px 15px; width: 614px;"><strong><a href="http://www.ringsidepolitics.com/" target="_blank" rel="noopener noreferrer" class="d-s" style="color: #427fed; cursor: pointer; text-decoration: none; outline: none;">http://www.RingsidePolitics.com</a></strong></div>
</div>
<div class="R3" style="display: table-row; color: #404040; font-family: Roboto, arial, sans-serif; font-size: 13px;">
<div class="vSa d-k-l" style="position: relative; display: table-cell; color: #888888; font-size: 15px; padding: 10px 0px; text-align: right; width: 94px;"><strong>Other</strong></div>
<div class="wSa d-k-l" style="position: relative; display: table-cell; padding: 10px 23px 10px 15px; width: 614px;"><strong><a href="http://t.co/87DvOIWoZG" target="_blank" rel="noopener noreferrer" class="d-s" style="color: #427fed; cursor: pointer; text-decoration: none; outline: none;">http://t.co/87DvOIWoZG</a></strong></div>
</div>
<div class="R3" style="display: table-row; color: #404040; font-family: Roboto, arial, sans-serif; font-size: 13px;">
<div class="vSa d-k-l" style="position: relative; display: table-cell; color: #888888; font-size: 15px; padding: 10px 0px; text-align: right; width: 94px;"><strong>Linkedin</strong></div>
<div class="wSa d-k-l" style="position: relative; display: table-cell; padding: 10px 23px 10px 15px; width: 614px;"><strong><a href="https://www.linkedin.com/profile/view?id=8849915" target="_blank" rel="noopener noreferrer" class="d-s" style="color: #427fed; cursor: pointer; text-decoration: none; outline: none;">https://www.linkedin.com/profile/view?id=8849915</a></strong></div>
</div>
<div class="R3" style="display: table-row; color: #404040; font-family: Roboto, arial, sans-serif; font-size: 13px;">
<div class="vSa d-k-l" style="position: relative; display: table-cell; color: #888888; font-size: 15px; padding: 10px 0px; text-align: right; width: 94px;"><strong>Twitter</strong></div>
<div class="wSa d-k-l" style="position: relative; display: table-cell; padding: 10px 23px 10px 15px; width: 614px;"><strong><a href="https://twitter.com/jeffcrouere" target="_blank" rel="noopener noreferrer" class="d-s" style="color: #427fed; cursor: pointer; text-decoration: none; outline: none;">https://twitter.com/jeffcrouere</a></strong></div>
</div>
<div class="R3" style="display: table-row; color: #404040; font-family: Roboto, arial, sans-serif; font-size: 13px;">
<div class="vSa d-k-l" style="position: relative; display: table-cell; color: #888888; font-size: 15px; padding: 10px 0px; text-align: right; width: 94px;"><strong>Facebook</strong></div>
<div class="wSa d-k-l" style="position: relative; display: table-cell; padding: 10px 23px 10px 15px; width: 614px;"><strong><a href="https://www.facebook.com/jeff.crouere" target="_blank" rel="noopener noreferrer" class="d-s" style="color: #427fed; cursor: pointer; text-decoration: none; outline: none;">https://www.facebook.com/jeff.crouere</a></strong></div>
</div>
<div class="R3" style="display: table-row; color: #404040; font-family: Roboto, arial, sans-serif; font-size: 13px;">
<div class="vSa d-k-l" style="position: relative; display: table-cell; color: #888888; font-size: 15px; padding: 10px 0px; text-align: right; width: 94px;"><strong>Klout</strong></div>
<div class="wSa d-k-l" style="position: relative; display: table-cell; padding: 10px 23px 10px 15px; width: 614px;"><strong><a href="http://klout.com/jeffcrouere" target="_blank" rel="noopener noreferrer" class="d-s" style="color: #427fed; cursor: pointer; text-decoration: none; outline: none;">http://klout.com/jeffcrouere</a></strong></div>
</div></p>
<span class="itemAuthorUrl"><i class="icon-globe"></i> <a rel="me" href="http://www.ringsidepolitics.com" target="_blank">www.ringsidepolitics.com</a></span>
<div class="clr"></div>

<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorLatest">
<h3>Latest from Jeff Crouere</h3>
<ul>
<li class="even">
<a href="/bb/item/1063213-rand-paul-stands-tall-opposing-more-federal-debt">Rand Paul stands tall opposing more federal debt</a>
</li>
<li class="odd">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063206-donald-trump-carries-on-ronald-reagan-s-america-the-positive-baton">Donald Trump carries on Ronald Reagan's "America, the Positive" baton</a>
</li>
<li class="even">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063202-crouere-memo-bombshell-mueller-trump-hater-witch-hunt-must-end">Crouere: Memo Bombshell, Mueller, Trump-hater witch hunt must end!!</a>
</li>
<li class="odd">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063194-dems-disrespect-trump-usa-as-america-drools-over-president-s-speech">Dems disrespect Trump, USA as America drools over President's speech</a>
</li>
<li class="even">
<a href="/bb/item/1063187-obama-farakkhan-picture-paints-one-million-men-words">Obama, Farakkhan picture paints one million men words</a>
</li>
</ul>
<div class="clr"></div>
</div>

<div class="itemRelated">
<h3>Related items</h3>
<ul>
<li class="even">
<a class="itemRelTitle" href="/bb/donald-trump-news-today/donald-trump-news/item/1063226-temporary-clearances-problem-makes-trump-administration-a-reckless-security-risk">Temporary clearances problem makes Trump administration a reckless security risk</a>
</li>
<li class="odd">
<a class="itemRelTitle" href="/bb/donald-trump-news-today/donald-trump-news/item/1063224-key-to-trump-s-infrastructure-plan-is-overcoming-roadblocks">Key to Trump&#039;s infrastructure plan is overcoming roadblocks</a>
</li>
<li class="even">
<a class="itemRelTitle" href="/bb/donald-trump-news-today/donald-trump-news/item/1063221-michael-cohen-trump-team-just-keep-on-giving-to-media-stormy">Michael Cohen, Trump Team just keep on giving to media stormy</a>
</li>
<li class="odd">
<a class="itemRelTitle" href="/bb/donald-trump-news-today/donald-trump-news/item/1063220-trump-hypocritically-abuses-due-process-in-porter-s-wives-abuses-controversies">Trump hypocritically abuses due process in Porter&#039;s wives abuses controversies</a>
</li>
<li class="even">
<a class="itemRelTitle" href="/bb/state-of-louisiana/item/1063218-trump-s-infrastructure-plan-governor-edwards-can-louisiana-participate">Trump&#039;s infrastructure plan, Governor Edwards, can Louisiana participate?</a>
</li>
<li class="clr"></li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>

<div class="itemNavigation">
<span class="itemNavigationTitle">More in this category:</span>
<a class="itemPrevious" href="/bb/donald-trump-news-today/donald-trump-news/item/1063226-temporary-clearances-problem-makes-trump-administration-a-reckless-security-risk">&laquo; Temporary clearances problem makes Trump administration a reckless security risk</a>
</div>



<a name="itemCommentsAnchor" id="itemCommentsAnchor"></a>
<div class="itemComments">
<div class="itemCommentsLoginFirst">Login to post comments</div>
</div>
<div class="itemBackToTop">
<a class="k2Anchor" href="/bb/donald-trump-news-today/donald-trump-news/item/1063228-mitt-romney-launches-utah-us-senate-bid-to-take-on-donald-trump#startOfPageId1063228">
back to top </a>
</div>
<div class="clr"></div>
</div>


</div>
</div>
</div>
</div>
<div class="rt-sidebar-wrapper rt-grid-3 ">
<div class="rt-sidebar-block">
<div id="rt-sidebar-a">
<div class="rt-social-buttons rt-block">
<div class="clear"></div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Advertisers/Sponsors</span></h2> </div>
<div class="module-content">
<div class='mod_ijoomlazone' id='ijoomlazone725'><div class='adg_row'><div class='adg_cell'></div></div></div> </div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<p><a href="http://www.latter-blum.com"><img src="/images/rocket/latter-blum2.gif" alt="latter-blum2" style="vertical-align: middle; display: block; margin-left: auto; margin-right: auto;" /></a></p></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Dead Pelican</span></h2> </div>
<div class="module-content">
<div class="custom">
<p><a href="http://thedeadpelican.com"><img src="/images/stories/Optimized-DeadPelican2_1_1.jpg" alt="Optimized-DeadPelican2 1 1" style="display: block; margin-left: auto; margin-right: auto;" /></a></p></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</section>
<section id="rt-bodybottom-surround">
<div class="rt-container">
<div id="rt-mainbottom">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Bayoubuzz, Donald Trump, Cloud </span></h2> </div>
<div class="module-content">
<div id="k2ModuleBox768" class="k2TagCloudBlock">
<a href="/issues/itemlist/tag/2017" style="font-size:62%" title="2 items tagged with 2017">
2017	</a>
<a href="/issues/itemlist/tag/Bob Corker" style="font-size:63%" title="3 items tagged with Bob Corker">
Bob Corker	</a>
<a href="/issues/itemlist/tag/Charlottesville" style="font-size:63%" title="3 items tagged with Charlottesville">
Charlottesville	</a>
<a href="/issues/itemlist/tag/CNN" style="font-size:64%" title="4 items tagged with CNN">
CNN	</a>
<a href="/issues/itemlist/tag/Common Cause" style="font-size:64%" title="4 items tagged with Common Cause">
Common Cause	</a>
<a href="/issues/itemlist/tag/DACA" style="font-size:67%" title="6 items tagged with DACA">
DACA	</a>
<a href="/issues/itemlist/tag/Donald Trump" style="font-size:200%" title="109 items tagged with Donald Trump">
Donald Trump	</a>
<a href="/issues/itemlist/tag/Donald Trump Jr" style="font-size:63%" title="3 items tagged with Donald Trump Jr">
Donald Trump Jr	</a>
<a href="/issues/itemlist/tag/Donald Trump News Today" style="font-size:75%" title="12 items tagged with Donald Trump News Today">
Donald Trump News Today	</a>
<a href="/issues/itemlist/tag/Fake news" style="font-size:67%" title="6 items tagged with Fake news">
Fake news	</a>
<a href="/issues/itemlist/tag/FBI" style="font-size:64%" title="4 items tagged with FBI">
FBI	</a>
<a href="/issues/itemlist/tag/Fire and Fury" style="font-size:64%" title="4 items tagged with Fire and Fury">
Fire and Fury	</a>
<a href="/issues/itemlist/tag/GOP" style="font-size:66%" title="5 items tagged with GOP">
GOP	</a>
<a href="/issues/itemlist/tag/Hillary Clinton" style="font-size:68%" title="7 items tagged with Hillary Clinton">
Hillary Clinton	</a>
<a href="/issues/itemlist/tag/James Comey" style="font-size:63%" title="3 items tagged with James Comey">
James Comey	</a>
<a href="/issues/itemlist/tag/Jeff Sessions" style="font-size:64%" title="4 items tagged with Jeff Sessions">
Jeff Sessions	</a>
<a href="/issues/itemlist/tag/John Kelly" style="font-size:64%" title="4 items tagged with John Kelly">
John Kelly	</a>
<a href="/issues/itemlist/tag/John Kennedy" style="font-size:63%" title="3 items tagged with John Kennedy">
John Kennedy	</a>
<a href="/issues/itemlist/tag/Lindsey Graham" style="font-size:63%" title="3 items tagged with Lindsey Graham">
Lindsey Graham	</a>
<a href="/issues/itemlist/tag/Michael Flynn" style="font-size:64%" title="4 items tagged with Michael Flynn">
Michael Flynn	</a>
<a href="/issues/itemlist/tag/Michael Wolff" style="font-size:63%" title="3 items tagged with Michael Wolff">
Michael Wolff	</a>
<a href="/issues/itemlist/tag/Mitch McConnell" style="font-size:64%" title="4 items tagged with Mitch McConnell">
Mitch McConnell	</a>
<a href="/issues/itemlist/tag/Mueller investigation" style="font-size:63%" title="3 items tagged with Mueller investigation">
Mueller investigation	</a>
<a href="/issues/itemlist/tag/NFL" style="font-size:63%" title="3 items tagged with NFL">
NFL	</a>
<a href="/issues/itemlist/tag/Obama" style="font-size:68%" title="7 items tagged with Obama">
Obama	</a>
<a href="/issues/itemlist/tag/Obamacare" style="font-size:63%" title="3 items tagged with Obamacare">
Obamacare	</a>
<a href="/issues/itemlist/tag/Paul Manafort" style="font-size:63%" title="3 items tagged with Paul Manafort">
Paul Manafort	</a>
<a href="/issues/itemlist/tag/Putin" style="font-size:64%" title="4 items tagged with Putin">
Putin	</a>
<a href="/issues/itemlist/tag/Quin Hillyer" style="font-size:63%" title="3 items tagged with Quin Hillyer">
Quin Hillyer	</a>
<a href="/issues/itemlist/tag/Rex Tillerson" style="font-size:63%" title="3 items tagged with Rex Tillerson">
Rex Tillerson	</a>
<a href="/issues/itemlist/tag/Robert Mueller" style="font-size:77%" title="14 items tagged with Robert Mueller">
Robert Mueller	</a>
<a href="/issues/itemlist/tag/Rob Porter" style="font-size:62%" title="2 items tagged with Rob Porter">
Rob Porter	</a>
<a href="/issues/itemlist/tag/Roy Moore" style="font-size:66%" title="5 items tagged with Roy Moore">
Roy Moore	</a>
<a href="/issues/itemlist/tag/Sarah Huckabee Sanders" style="font-size:63%" title="3 items tagged with Sarah Huckabee Sanders">
Sarah Huckabee Sanders	</a>
<a href="/issues/itemlist/tag/State of the Union" style="font-size:63%" title="3 items tagged with State of the Union">
State of the Union	</a>
<a href="/issues/itemlist/tag/Steve Bannon" style="font-size:68%" title="7 items tagged with Steve Bannon">
Steve Bannon	</a>
<a href="/issues/itemlist/tag/Stormy Daniels" style="font-size:64%" title="4 items tagged with Stormy Daniels">
Stormy Daniels	</a>
<a href="/issues/itemlist/tag/tax reform" style="font-size:67%" title="6 items tagged with tax reform">
tax reform	</a>
<a href="/issues/itemlist/tag/Trump" style="font-size:71%" title="9 items tagged with Trump">
Trump	</a>
<a href="/issues/itemlist/tag/us economy" style="font-size:64%" title="4 items tagged with us economy">
us economy	</a>
<div class="clr"></div>
</div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</section>
<footer id="rt-footer-surround">
<div class="rt-container">
<div id="rt-copyright">
<div class="rt-flex-container">
<div class="rt-grid-4 rt-alpha">
<div class="rt-block rt-branding">
<a href="https://www.bayoubuzz.com/" title="Bayoubuzz" class="rt-powered-by"></a>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Privacy</span></h2> </div>
<div class="module-content">
<div class="custom">

<div style="font-family: arial;"><a href="/Bayoubuzzprivacy.pdf"><strong>Privacy Policy</strong></a><span></span></div></div>
</div>
</div>
</div>
</div>
<div class="rt-grid-4">
<div class="rt-copyright-content rt-block">
Designed by RocketTheme	</div>
</div>
<div class="rt-grid-4 rt-omega">
<div class="clear"></div>
<div class="rt-block">
<a href="#" id="gantry-totop" rel="nofollow">Top</a>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</footer>
<div id="rt-debug">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class='mod_ijoomlazone' id='ijoomlazone727'><div class='adg_row'><div class='adg_cell'></div></div></div> </div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
<script data-cfasync="false" src="/cdn-cgi/scripts/d07b1474/cloudflare-static/email-decode.min.js"></script></body>
</html>
