<!doctype html>
<html prefix="og: http://ogp.me/ns#" xml:lang="en-gb" lang="en-gb">
<head>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KTNXD4L');</script>

<script src="//widget.manychat.com/90206201070.js" async="async">
</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<base href="https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-elections/item/1063678-john-kennedy-all-mouth-but-no-feat-louisiana-governor-run-stab-launches" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="American Bridge,Louisiana governor,John Bel Edwards,John Kennedy,Senator John Kennedy" />
<meta name="title" content="John Kennedy &quot;all mouth but no feat&quot;? Louisiana governor run stab launches" />
<meta name="author" content="Stephen Sabludowsky" />
<meta property="og:url" content="https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-elections/item/1063678-john-kennedy-all-mouth-but-no-feat-louisiana-governor-run-stab-launches" />
<meta property="og:title" content="John Kennedy &quot;all mouth but no feat&quot;? Louisiana governor run stab launches" />
<meta property="og:type" content="article" />
<meta property="og:description" content="John Kennedy &quot;all mouth but no feat&quot;? Louisiana governor run stab launches with American Bridge on attack upon Senator" />
<meta name="description" content="John Kennedy &quot;all mouth but no feat&quot;? Louisiana governor run stab launches with American Bridge on attack upon Senator" />
<meta name="generator" content="Joomla! - Open Source Content Management" />
<title>John Kennedy &quot;all mouth but no feat&quot;? Louisiana governor run stab launches</title>
<link href="https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-elections/item/1063678-john-kennedy-all-mouth-but-no-feat-louisiana-governor-run-stab-launches" rel="canonical" />
<link href="https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-elections/item/1063678-john-kennedy-all-mouth-but-no-feat-louisiana-governor-run-stab-launches/amp" rel="amphtml" />
<link href="/templates/rt_tessellate/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_0.css" />
<link href="https://cdnjs.cloudflare.com/ajax/libs/magnific-popup.js/1.1.0/magnific-popup.min.css" rel="stylesheet" type="text/css" />
<link href="https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/css/simple-line-icons.min.css" rel="stylesheet" type="text/css" />
<link href="/components/com_k2/css/k2.css?v=2.9.0" rel="stylesheet" type="text/css" />
<link href="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9/themes/base/jquery-ui.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_1.css" />
<link href="/modules/mod_latestnewsenhanced/styles/common_styles-min.css" rel="stylesheet" type="text/css" />
<link href="https://www.bayoubuzz.com/plugins/content/pdf_embed/assets/css/style.css" rel="stylesheet" type="text/css" />
<link href="/plugins/system/jcemediabox/css/jcemediabox.css?1d12bb5a40100bbd1841bfc0e498ce7b" rel="stylesheet" type="text/css" />
<link href="/plugins/system/jcemediabox/themes/standard/css/style.css?50fba48f56052a048c5cf30829163e4d" rel="stylesheet" type="text/css" />
<link href="/plugins/system/rokbox/assets/styles/rokbox.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_2.css" />
<link href="https://www.bayoubuzz.com/media/editors/arkeditor/css/squeezebox.css" rel="stylesheet" type="text/css" />
<link href="https://www.bayoubuzz.com/modules/mod_ijoomla_adagency_zone/tmpl/mod_ijoomlazone.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_3.css" />
<script type="application/json" class="joomla-script-options new">{"csrf.token":"0ff5483797a4574a73396cf3638e05d2","system.paths":{"root":"","base":""}}</script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/24020acda323e24ee9ed1ff0fe0c1bb2_0.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js" type="text/javascript"></script>
<script src="/plugins/system/jqueryeasy/jquerynoconflict.js" type="text/javascript"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9/jquery-ui.min.js" type="text/javascript"></script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/24020acda323e24ee9ed1ff0fe0c1bb2_1.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/magnific-popup.js/1.1.0/jquery.magnific-popup.min.js" type="text/javascript"></script>
<script src="/media/k2/assets/js/k2.frontend.js?v=2.9.0&amp;sitepath=/" type="text/javascript"></script>
<script src="/plugins/system/jcemediabox/js/jcemediabox.js?0c56fee23edfcb9fbdfe257623c5280e" type="text/javascript"></script>
<script src="/plugins/system/rokbox/assets/js/rokbox.js" type="text/javascript"></script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/24020acda323e24ee9ed1ff0fe0c1bb2_2.js"></script>
<script src="/modules/mod_roknavmenu/themes/default/js/rokmediaqueries.js" type="text/javascript"></script>
<script src="/modules/mod_roknavmenu/themes/default/js/sidemenu.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/media/editors/arkeditor/js/jquery.easing.min.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/media/editors/arkeditor/js/squeezebox.min.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/modules/mod_ijoomla_adagency_zone/includes/helper.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/components/com_adagency/includes/js/domready.js" type="text/javascript"></script>
<script type="text/javascript">
JCEMediaBox.init({popup:{width:"",height:"",legacy:0,lightbox:0,shadowbox:0,resize:1,icons:1,overlay:1,overlayopacity:0.8,overlaycolor:"#000000",fadespeed:500,scalespeed:500,hideobjects:0,scrolling:"fixed",close:2,labels:{'close':'Close','next':'Next','previous':'Previous','cancel':'Cancel','numbers':'{$current} of {$total}'},cookie_expiry:"",google_viewer:0},tooltip:{className:"tooltip",opacity:0.8,speed:150,position:"br",offsets:{x: 16, y: 16}},base:"/",imgpath:"plugins/system/jcemediabox/img",theme:"standard",themecustom:"",themepath:"plugins/system/jcemediabox/themes",mediafallback:0,mediaselector:"audio,video"});if (typeof RokBoxSettings == 'undefined') RokBoxSettings = {pc: '100'};window.addEvent('domready', function(){
            this.RENDERER = 'canvas';
            if (typeof this.MESH != 'undefined'){
                this.MESH.ambient = '#08162A';
                this.MESH.diffuse = '#3068D3';
            }
            if (typeof this.LIGHT != 'undefined'){
                this.LIGHT.ambient = '#08162A';
                this.LIGHT.diffuse = '#3068D3';
            }
        });		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
		__gaTracker('create', '', 'auto');
		__gaTracker('send', 'pageview');
	(function()
				{
					if(typeof jQuery == 'undefined')
						return;
					
					jQuery(function($)
					{
						if($.fn.squeezeBox)
						{
							$( 'a.modal' ).squeezeBox({ parse: 'rel' });
				
							$( 'img.modal' ).each( function( i, el )
							{
								$(el).squeezeBox({
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							})
						}
						else if(typeof(SqueezeBox) !== 'undefined')
						{
							$( 'img.modal' ).each( function( i, el )
							{
								SqueezeBox.assign( el, 
								{
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							});
						}
						
						function jModalClose() 
						{
							if(typeof(SqueezeBox) == 'object')
								SqueezeBox.close();
							else
								ARK.squeezeBox.close();
						}
					
					});
				})();
	</script>
<link href="http://feeds.feedburner.com/bayoubuzz/BnFN" rel="alternate" type="application/rss+xml" title="Latest Buzz" />
<link href="http://feeds.feedburner.com/bayoubuzz/QPkg" rel="alternate" type="application/rss+xml" title="News" />
<link href="http://feeds.feedburner.com/bayoubuzz/GTum" rel="alternate" type="application/rss+xml" title="Buzz" />
<link href="http://feeds.feedburner.com/TrumpArticles" rel="alternate" type="application/rss+xml" title="Trump articles" />
<link href="http://feeds.feedburner.com//KGuc" rel="alternate" type="application/rss+xml" title="Louisiana news" />
<link href="http://feeds.feedburner.com/DonaldTrumpLatestNews" rel="alternate" type="application/atom+xml" title="Donald Trump Latest News" />
<link href="http://feeds.feedburner.com/bayoubuzz/oxlh" rel="alternate" type="application/atom+xml" title="New Orleans News" />
<link href="http://feeds.feedburner.com/StateOfLouisiana" rel="alternate" type="application/atom+xml" title="State of Louisiana" />

<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "WebSite",
                "url": "https://www.bayoubuzz.com",
                "potentialAction": {
                    "@type": "SearchAction",
                    "target": "https://www.bayoubuzz.com/index.php?option=com_search&searchphrase=all&searchword={search_term}",
                    "query-input": "required name=search_term"
                }
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "Organization",
                "url": "https://www.bayoubuzz.com",
                "logo": "https://www.bayoubuzz.com/images/logo-cropped.png"
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "Organization",
                "name": "Bayoubuzz",
                "url": "https://www.bayoubuzz.com",
                "sameAs": [
                  "https://www.facebook.com/Bayoubuzz/",
"https://twitter.com/BayoubuzzSteve",
"https://plus.google.com/+StephenSabludowsky",
"https://www.youtube.com/user/bayoubuzz",
"https://www.linkedin.com/in/steve-sabludowsky-631678/"
                ]
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "BreadcrumbList",
                "itemListElement": [{
                    "@type": "ListItem",
                    "position": 1,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/",
                        "name": "Home"
                    }
                },{
                    "@type": "ListItem",
                    "position": 2,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb",
                        "name": "BB"
                    }
                },{
                    "@type": "ListItem",
                    "position": 3,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/state-of-louisiana/itemlist",
                        "name": "State of Louisiana"
                    }
                },{
                    "@type": "ListItem",
                    "position": 4,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-elections",
                        "name": "Louisiana elections"
                    }
                },{
                    "@type": "ListItem",
                    "position": 5,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-elections/item/1063678-john-kennedy-all-mouth-but-no-feat-louisiana-governor-run-stab-launches",
                        "name": "John Kennedy &quot;all mouth but no feat&quot;? Louisiana governor run stab launches"
                    }
                }]
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org/",
                "@type": "Article",
                "mainEntityOfPage": {
                    "@type": "WebPage",
                    "@id": "https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-elections/item/1063678-john-kennedy-all-mouth-but-no-feat-louisiana-governor-run-stab-launches"
                },
                "headline": "John Kennedy \"all mouth but no feat\"? Louisiana governor run stab launches",
                "description": "John Kennedy \"all mouth but no feat\"? Louisiana governor run stab launches with American Bridge on attack upon Senator",
                "image": {
                    "@type": "ImageObject",
                    "url": "https://www.bayoubuzz.com/",
                    "height": 800,
                    "width": 800
                },
                "author": {
                    "@type": "Person",
                    "name": "Stephen Sabludowsky"
                },
                "publisher": {
                    "@type": "Organization",
                    "name": "Bayoubuzz",
                    "logo": {
                        "@type": "ImageObject",
                        "url": "https://www.bayoubuzz.com/images/logo-cropped.png",
                        "width": 600,
                        "height": 60
                    }
                },
                "datePublished" : "2018-11-30T17:24:33-06:00",
                "dateCreated" : "2018-11-30T17:24:33-06:00",
                "dateModified": "-001-11-30T00:00:00-06:00"
            }
            </script>

<script async="async" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<script type="text/javascript">
/*<![CDATA[*/

(function () {
  var scriptURL = 'https://sdks.shopifycdn.com/buy-button/latest/buy-button-storefront.min.js';
  if (window.ShopifyBuy) {
    if (window.ShopifyBuy.UI) {
      ShopifyBuyInit();
    } else {
      loadScript();
    }
  } else {
    loadScript();
  }

  function loadScript() {
    var script = document.createElement('script');
    script.async = true;
    script.src = scriptURL;
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(script);
    script.onload = ShopifyBuyInit;
  }

  function ShopifyBuyInit() {
    var client = ShopifyBuy.buildClient({
      domain: 'campaigns-and-elections.myshopify.com',
      storefrontAccessToken: '41f7f6c0815ab096514e1f3cb53e90f5',
    });

    ShopifyBuy.UI.onReady(client).then(function (ui) {
      ui.createComponent('collection', {
        id: 67191799867,
        node: document.getElementById('collection-component-20356addbf6'),
        moneyFormat: '%24%7B%7Bamount%7D%7D',
        options: {
  "product": {
    "variantId": "all",
    "contents": {
      "imgWithCarousel": false,
      "variantTitle": false,
      "description": false,
      "buttonWithQuantity": false,
      "quantity": false
    },
    "styles": {
      "product": {
        "@media (min-width: 601px)": {
          "max-width": "calc(25% - 20px)",
          "margin-left": "20px",
          "margin-bottom": "50px"
        }
      }
    }
  },
  "cart": {
    "contents": {
      "button": true
    },
    "styles": {
      "footer": {
        "background-color": "#ffffff"
      }
    }
  },
  "modalProduct": {
    "contents": {
      "img": false,
      "imgWithCarousel": true,
      "variantTitle": false,
      "buttonWithQuantity": true,
      "button": false,
      "quantity": false
    },
    "styles": {
      "product": {
        "@media (min-width: 601px)": {
          "max-width": "100%",
          "margin-left": "0px",
          "margin-bottom": "0px"
        }
      }
    }
  },
  "productSet": {
    "styles": {
      "products": {
        "@media (min-width: 601px)": {
          "margin-left": "-20px"
        }
      }
    }
  }
}
      });
    });
  }
})();
/*]]>*/
</script>
<body class="logo-type-custom logo-type-custom demostyle-type-preset4 headermode-type-animated headersurround-type-preset4 mainbody-overlay-light font-family-tessellate font-size-is-xlarge menu-type-dropdownmenu menu-dropdownmenu-position-header-b layout-mode-responsive col12 option-com-k2 menu-louisiana-elections ">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KTNXD4L"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script src="//widget.manychat.com/90206201070.js" async="async">
</script>
<div id="rt-page-surround">
<header id="rt-header-surround">
<div id="rt-fss-container" class="rt-fss-container">
<div id="rt-fss-output" class="rt-fss-container"></div>
</div>
<div class="rt-container">
<div id="rt-header">
<div class="rt-flex-container">
<div class="rt-grid-5 rt-alpha">
<div class="rt-logo-block">
<a href="/" id="rt-logo"></a>
</div>
</div>
<div class="rt-grid-7 rt-omega">
<div class="menu-block">
<div class="gf-menu-device-container responsive-type-panel">
</div>
<ul class="gf-menu l1 ">
<li class="item21 ">
<a class="item" href="/">
<span class="menu-item-bg">
Home </span>
</a>
</li>
<li class="item1782 parent active rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb">
<span class="menu-item-bg">
BB </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item1821 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/donald-trump-news-today">
<span class="menu-item-bg">
Donald Trump News Today </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1827 ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-news">
<span class="menu-item-bg">
Donald Trump News </span>
</a>
</li>
<li class="item1828 ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-news-tweets">
<span class="menu-item-bg">
Donald Trump news tweets </span>
</a>
</li>
<li class="item1933 ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-tags">
<span class="menu-item-bg">
Donald Trump Tags </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1788 ">
<a class="item" href="/bb/jon-bel-edwards">
<span class="menu-item-bg">
John Bel Edwards </span>
</a>
</li>
<li class="item1823 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/new-orleans-louisiana">
<span class="menu-item-bg">
New Orleans Louisiana </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1829 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections">
<span class="menu-item-bg">
New Orleans Elections </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l4">
<li class="item1866 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/michael-bagneris">
<span class="menu-item-bg">
Michael Bagneris </span>
</a>
</li>
<li class="item1867 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/latoya-cantrell">
<span class="menu-item-bg">
LaToya Cantrell </span>
</a>
</li>
<li class="item1868 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/desiree-charbonnet">
<span class="menu-item-bg">
Desiree Charbonnet </span>
</a>
</li>
<li class="item1869 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/troy-henry">
<span class="menu-item-bg">
Troy Henry </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1830 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections-twitter">
<span class="menu-item-bg">
New Orleans elections twitter </span>
</a>
</li>
<li class="item1831 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-news">
<span class="menu-item-bg">
New Orleans News </span>
</a>
</li>
<li class="item1934 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-louisiana-tag">
<span class="menu-item-bg">
New Orleans, Louisiana, Tag </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1824 parent active rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/state-of-louisiana">
<span class="menu-item-bg">
State of Louisiana </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1832 ">
<a class="item" href="/bb/state-of-louisiana/louisiana-legislature">
<span class="menu-item-bg">
Louisiana Legislature and Legislation </span>
</a>
</li>
<li class="item1833 active last ">
<a class="item" href="/bb/state-of-louisiana/louisiana-elections">
<span class="menu-item-bg">
Louisiana elections </span>
</a>
</li>
<li class="item1935 ">
<a class="item" href="/bb/state-of-louisiana/louisiana-tags-louisiana-news">
<span class="menu-item-bg">
Louisiana Tags, Louisiana news </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1978 ">
<a class="item" href="/bb/events">
<span class="menu-item-bg">
Events </span>
</a>
</li>
<li class="item2010 ">
<a class="item" href="/bb/winning-campaigns-and-elections">
<span class="menu-item-bg">
Winning campaigns and elections </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item82 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/buzz">
<span class="menu-item-bg">
Buzz </span>
 </a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
</div>
</li>
<li class="item758 ">
<a class="item" href="/rss">
<span class="menu-item-bg">
RSS </span>
</a>
</li>
<li class="item880 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bayoubuzz-videos">
<span class="menu-item-bg">
Bayoubuzz videos </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item1995 ">
<a class="item" href="/bayoubuzz-videos/louisiana-legislature-videos">
<span class="menu-item-bg">
Louisiana Legislature 2018 Videos </span>
</a>
</li>
<li class="item2001 ">
<a class="item" href="/bayoubuzz-videos/louisiana-business">
<span class="menu-item-bg">
Louisiana Business </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1492 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/2014-08-11-02-18-17">
<span class="menu-item-bg">
Webinars </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item2009 ">
<a class="item" href="/2014-08-11-02-18-17/our-elections-webinars">
<span class="menu-item-bg">
Our Elections Webinars </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1838 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/issues">
<span class="menu-item-bg">
Issues </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item1836 ">
<a class="item" href="/issues/confederate-monuments">
<span class="menu-item-bg">
Confederate monuments </span>
</a>
</li>
<li class="item1835 ">
<a class="item" href="/issues/john-bel-edwards">
<span class="menu-item-bg">
John Bel Edwards </span>
</a>
</li>
<li class="item1826 ">
<a class="item" href="/issues/new-orleans">
<span class="menu-item-bg">
New Orleans </span>
</a>
</li>
<li class="item1834 ">
<a class="item" href="/issues/mitch-landrieu">
<span class="menu-item-bg">
Mitch Landrieu </span>
</a>
</li>
<li class="item1789 ">
<a class="item" href="/issues/louisiana-legislature">
<span class="menu-item-bg">
Louisiana legislature </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1865 grouped ">
<a class="item" href="/forums">
<span class="menu-item-bg">
Forums </span>
</a>
</li>
<li class="item1930 ">
<a class="item" href="/tag">
<span class="menu-item-bg">
Tag </span>
</a>
</li>
<li class="item1942 ">
<a class="item" href="/feeds">
<span class="menu-item-bg">
Feeds </span>
</a>
</li>
</ul> <div class="clear"></div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div>
</div>
<div id="rt-drawer">
<div class="rt-flex-container">
<div class="clear"></div>
</div>
</div>
<div id="rt-top">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<p>&nbsp;</p>

<p>&nbsp;</p></div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
<div id="rt-breadcrumbs">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<ul class="breadcrumb">
<li>
You are here: &#160;
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/" class="pathway"><span>Home</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="1">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb" class="pathway"><span>BB</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="2">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb/state-of-louisiana/itemlist" class="pathway"><span>State of Louisiana</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="3">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb/state-of-louisiana/louisiana-elections" class="pathway"><span>Louisiana elections</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="4">
</li>
<li itemscope itemtype="https://schema.org/ListItem" class="active">
<span>
John Kennedy &quot;all mouth but no feat&quot;? Louisiana governor run stab launches </span>
<meta content="5">
</li>
</ul>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</header>
<section id="rt-mainbody-surround">
<div class="rt-container">
<div id="rt-main" class="mb9-sa3">
<div class="rt-flex-container">
<div class="rt-mainbody-wrapper rt-grid-9 ">
<div class="rt-component-block rt-block">
<div id="rt-mainbody">
<div class="component-content">

<span id="startOfPageId1063678"></span>
<div id="k2Container" class="itemView">


<div class="itemHeader">

<span class="itemDateCreated">
Friday, 30 November 2018 11:24	</span>

<h2 class="itemTitle">
John Kennedy &quot;all mouth but no feat&quot;? Louisiana governor run stab launches
</h2>

<span class="itemAuthor">
Written by <a rel="author" href="/issues/itemlist/user/62-stephensabludowsky">Stephen Sabludowsky</a>
</span>
</div>


<div class="itemToolbar">
<ul>

<li>
<span class="itemTextResizerTitle">font size</span>
<a href="#" id="fontDecrease">
<span>decrease font size</span>
</a>
<a href="#" id="fontIncrease">
<span>increase font size</span>
</a>
</li>

<li>
<a class="itemPrintLink" rel="nofollow" href="/bb/state-of-louisiana/louisiana-elections/item/1063678-john-kennedy-all-mouth-but-no-feat-louisiana-governor-run-stab-launches?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
<span>Print</span>
</a>
</li>

<li>
<a class="itemEmailLink" rel="nofollow" href="/component/mailto/?tmpl=component&amp;template=rt_tessellate&amp;link=dfc49d759e7d8fa65d15a22ae8717367ea1ecaaf" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
<span>Email</span>
</a>
</li>
</ul>
<div class="clr"></div>
</div>

<div class="itemRatingBlock">
<span>Rate this item</span>
<div class="itemRatingForm">
<ul class="itemRatingList">
<li class="itemCurrentRating" id="itemCurrentRating1063678" style="width:0%;"></li>
<li><a href="#" data-id="1063678" title="1 star out of 5" class="one-star">1</a></li>
<li><a href="#" data-id="1063678" title="2 stars out of 5" class="two-stars">2</a></li>
<li><a href="#" data-id="1063678" title="3 stars out of 5" class="three-stars">3</a></li>
<li><a href="#" data-id="1063678" title="4 stars out of 5" class="four-stars">4</a></li>
<li><a href="#" data-id="1063678" title="5 stars out of 5" class="five-stars">5</a></li>
</ul>
<div id="itemRatingLog1063678" class="itemRatingLog">(0 votes)</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemBody">



<div class="itemIntroText">
<p><img src="/images/sound-bite_7.jpg" alt="sound bite 7" width="386" height="358" style="display: block; margin-left: auto; margin-right: auto;" /></p>
<p>Might folksy US Senator John Neely Kennedy’s greatest strength, as of lately, morph into a sore political Achilles heel?</p>
<p>That is apparently what Democratic political Super PAC American Bridge is shooting for as the Senator keeps us all in suspense. The mystery is whether he will jump into the campaign waters once again, this time, for Louisiana Governor.</p>
</div>

<div class="itemFullText">
<p>&nbsp;</p>
<p>The American Bridge Super PAC has launched its own cutesy folksy assault against Kennedy armed with a campaign ad at the moment that a political <a href="/bb/state-of-louisiana/louisiana-elections/item/1063675-kennedy-if-runs-leads-edwards-trump-s-favorables-skyrocket-in-pinsonat-s-louisiana-poll">poll by Bernie Pinsona</a>t shows that Kennedy is the front-runner in a run against Governor John Bel Edwards.</p>
<p>Quips by Kennedy have been the TV charm. It has been arduous to turn on one of the cable networks without seeing Kennedy’s face chatting with a talking head anchor. Which is quite&nbsp;impressive</p>
<p>media appearances, it appears his popularity has shot through the roof. In just one year, his favorables have gone up ten points.</p>
<p>Pinsonat in presenting his poll said:</p>
<blockquote>
<p>“Whether Kennedy runs or not, 2018 has been a very good year for his political fortunes. Senator John Kennedy makes the biggest popularity gain in survey as he jumps from a 51% positive job rating last November to now 61%. Kennedy strengthened his excellent job approval ratings with all voters to 24%. His excellent job ratings with white voters are now 34% and good 42% for a positive job rating of 76%. His negative job rating was 30% with all voters. Should Kennedy decide to run for governor, his popularity and Louisiana’s strong tilt towards electing republicans – as of today, he could be considered the favorite.”</p>
</blockquote>

<div class="custom">
<script type="text/javascript">
var bannersnack_embed = {"hash":"b1my7ewap","width":600,"height":200,"t":1542912519,"userId":7017733,"responsive":true,"type":"html5"};
</script>
<script type="text/javascript" src="//cdn.bannersnack.com/iframe/embed.js"></script></div>

<p>Indeed, Kennedy has come up with some whoppers in quotesville. Here are just a few from <a href="https://www.cnn.com/2018/02/14/politics/john-neely-kennedy-quotes/index.html">CNN</a> and <a href="https://www.nola.com/expo/erry-2018/03/4767052e78/15_more_memorable_quips_from_j.html">NOLA.com</a>:</p>
<p>“Our country was founded by geniuses, but it’s being run by idiots,” Kennedy said in January.</p>
<p>“As best I can tell, they’re all held together with spit,” he observed of the Senate’s immigration proposal in February.</p>
<p>And of the Senate’s amendment process, he said last month: “I think it sucks.”</p><p>
<div style="text-align:left;">

<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-0689976758489378" data-ad-slot="5499311424" data-ad-type="text_image" data-color-border="FFFFFF" data-color-bg="FFFFFF" data-color-link="0088CC" data-color-text="555555" data-color-url="AAAAAA"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></p>
<p>Kennedy admitted he would miss his role as Senate truth-teller should he become governor and emphasized that he‘s undecided on a run. He estimated he will make up his mind by the fall and said he’s told state Republicans interested in the job and not to wait for him.</p>
<p>“It’s been my experience in politics that you can try and plan it out: ‘I’m going to hit the three ball which will hit the eight ball,’” he said, shaking his head. “You’ve just got to go run and try to do everything right. And then have a little luck.”</p>
<p>&nbsp;"I think they're making a big mistake if they start tacking on extraneous issues to the budget. We have enough trouble doing a budget by itself. We haven't had one since Moses walked the earth. It's embarrassing."</p>
<p>"Facebook is a great company, but it's no longer a company; it's a country. That's how powerful it is. And its behavior lately has kind of been getting into the foothills of creepy."</p>
<p>But will Kennedy’s cracker-barrel pith turn into a campaign "yeth", this election cycle?</p>
<p>Not if American Bridge has it’s way, it seems.</p>
<p style="text-align: justify;">Here is the press-release that organization sent out Thursday which came equipped with a homespun website and arguably "horse-sense" ad.&nbsp; The point of the attack is that Kennedy is all mouth but no feat.</p>
<blockquote>
<div><strong>New Ads and Website Featuring Bobby Jindal Show “Senator Soundbite” John Kennedy What to Expect if He Runs for Governor</strong></div>
<p><em><a href="https://americanbridgepac.us13.list-manage.com/track/click?u=ee1bfee563d1c69fe20eff85d&amp;id=68e43f8fae&amp;e=8b8d31f947" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://americanbridgepac.us13.list-manage.com/track/click?u%3Dee1bfee563d1c69fe20eff85d%26id%3D68e43f8fae%26e%3D8b8d31f947&amp;source=gmail&amp;ust=1543686119473000&amp;usg=AFQjCNEqLs7bziD0kjDYQ9Gk08wzfYue8g">Watch the ad here</a></em><br /><br /><em>See the new website,&nbsp;<a href="https://americanbridgepac.us13.list-manage.com/track/click?u=ee1bfee563d1c69fe20eff85d&amp;id=9456b2a513&amp;e=8b8d31f947" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://americanbridgepac.us13.list-manage.com/track/click?u%3Dee1bfee563d1c69fe20eff85d%26id%3D9456b2a513%26e%3D8b8d31f947&amp;source=gmail&amp;ust=1543686119473000&amp;usg=AFQjCNFUgs7_V6u4x1FB_MooYUGmx5pkbQ">SenatorSoundbite.com</a></em></p>
<p><span class="il">American</span>&nbsp;<span class="il">Bridge</span>&nbsp;launched its<a href="https://americanbridgepac.us13.list-manage.com/track/click?u=ee1bfee563d1c69fe20eff85d&amp;id=1c9d525ecd&amp;e=8b8d31f947" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://americanbridgepac.us13.list-manage.com/track/click?u%3Dee1bfee563d1c69fe20eff85d%26id%3D1c9d525ecd%26e%3D8b8d31f947&amp;source=gmail&amp;ust=1543686119473000&amp;usg=AFQjCNHyaCf2gl3GXMosFoFFZEu_zWtRmw">&nbsp;first ads</a>&nbsp;of the 2019 election cycle today to show Washington’s "Senator Soundbite” John Kennedy what he can expect should he decide to run for Louisiana Governor. Kennedy says he will make his decision by December 3.</p>
<p>The digital ads begin running today in Louisiana, including in Senator Kennedy’s hometown of Madisonville. They also feature a glowing endorsement of Kennedy from one of the&nbsp;<a href="https://americanbridgepac.us13.list-manage.com/track/click?u=ee1bfee563d1c69fe20eff85d&amp;id=1d0637e120&amp;e=8b8d31f947" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://americanbridgepac.us13.list-manage.com/track/click?u%3Dee1bfee563d1c69fe20eff85d%26id%3D1d0637e120%26e%3D8b8d31f947&amp;source=gmail&amp;ust=1543686119473000&amp;usg=AFQjCNF0ROIJwua9apEw632162jJnialOQ">most unpopular politicians</a>&nbsp;in Louisiana, failed presidential candidate Bobby Jindal. The ads coincide with the launch of a new website,&nbsp;<a href="https://americanbridgepac.us13.list-manage.com/track/click?u=ee1bfee563d1c69fe20eff85d&amp;id=9179ff9794&amp;e=8b8d31f947" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://americanbridgepac.us13.list-manage.com/track/click?u%3Dee1bfee563d1c69fe20eff85d%26id%3D9179ff9794%26e%3D8b8d31f947&amp;source=gmail&amp;ust=1543686119473000&amp;usg=AFQjCNFolzmpnAejgolyUv8cUAiZkGyixA">SenatorSoundbite.com</a>to chronicle how in Washington, John Kennedy is focused on promoting himself, not helping Louisiana families. While he has no major legislative accomplishments to speak of, Kennedy has been very busy promoting himself on national television.</p>
<p>Just this year alone, Kennedy has already done over 100 media interviews&nbsp; -- and the year isn’t even over. Unfortunately for Louisiana families, this is all too familiar. Louisiana suffered for eight years while Bobby Jindal traveled the country promoting his national ambitions.</p>

<div id="lnee_739" class="lnee newslist vertical">
<ul class="latestnews-items">
<li class="latestnews-item id-1063675 catid-381">
<div class="news odd head_left">
<div class="innernews">
<div class="newshead picturetype">
<div class="picture">
<div class="innerpicture">
<a href="/bb/state-of-louisiana/louisiana-elections/item/1063675-kennedy-if-runs-leads-edwards-trump-s-favorables-skyrocket-in-pinsonat-s-louisiana-poll" class="hasTooltip" title="Kennedy, if runs, leads Edwards; Trump’s favorables skyrocket in Pinsonat’s Louisiana poll"> <img alt="Kennedy, if runs, leads Edwards; Trump’s favorables skyrocket in Pinsonat’s Louisiana poll" src="/images/rocket/thumbnails/lnee/thumb_739_1063675.jpg" /> </a>
</div>
</div>
</div>
<div class="newsinfo">
<h4 class="newstitle">
<a href="/bb/state-of-louisiana/louisiana-elections/item/1063675-kennedy-if-runs-leads-edwards-trump-s-favorables-skyrocket-in-pinsonat-s-louisiana-poll" class="hasTooltip" title="Kennedy, if runs, leads Edwards; Trump’s favorables skyrocket in Pinsonat’s Louisiana poll"> <span>Kennedy, if runs, leads Edwards; Trump’s favorables skyrocket in Pinsonat’s Louisiana poll</span>
</a>
</h4>
<div class="newsintro">
US Senator John Kennedy, if he runs, leads Louisiana Governor John Bel Edwards; Trump’s favorables skyrocket in Pinsonat’s Louisiana poll </div>
</div>
</div>
</div>
</li>
<li class="latestnews-item id-1063663 catid-381">
<div class="news even head_left">
<div class="innernews">
<div class="newshead picturetype">
<div class="picture">
<div class="innerpicture">
<a href="/bb/state-of-louisiana/louisiana-elections/item/1063663-crouere-john-kennedy-will-be-louisiana-s-next-governor-if-he-runs" class="hasTooltip" title="Crouere: John Kennedy will be Louisiana's next governor, if he runs"> <img alt="Crouere: John Kennedy will be Louisiana's next governor, if he runs" src="/images/rocket/thumbnails/lnee/thumb_739_1063663.jpg" /> </a>
</div>
</div>
</div>
<div class="newsinfo">
<h4 class="newstitle">
<a href="/bb/state-of-louisiana/louisiana-elections/item/1063663-crouere-john-kennedy-will-be-louisiana-s-next-governor-if-he-runs" class="hasTooltip" title="Crouere: John Kennedy will be Louisiana's next governor, if he runs"> <span>Crouere: John Kennedy will be Louisiana's next governor, if he runs</span>
</a>
</h4>
<div class="newsintro">
Crouere: John Kennedy will be Louisiana's next governor, if he runs--If he runs, Kennedy will be the favorite in the race and will be in a good position to defeat John Bel Edwards, the liberal Democrat who currently occupies the Governor’s mansion. </div>
</div>
</div>
</div>
</li>
</ul>
</div>

<p>&nbsp;&nbsp;“Louisiana is climbing out of the mess Bobby Jindal left behind, but Senator Soundbite John Kennedy would be Jindal on steroids,” said&nbsp;<span class="il">American</span>&nbsp;<span class="il">Bridge</span>&nbsp;spokesperson Zach Hudson. “Senator Kennedy’s record speaks for itself: more than a hundred media interviews, no accomplishments. Recycled soundbites might get John Kennedy on television in Washington and New York City, but they don’t do a thing to help Louisianans back home.”&nbsp;</p>
<p>Watch the ad below, and visit the new website at&nbsp;<a href="https://americanbridgepac.us13.list-manage.com/track/click?u=ee1bfee563d1c69fe20eff85d&amp;id=b25b3a8964&amp;e=8b8d31f947" target="_blank" rel="noopener noreferrer" data-saferedirecturl="https://www.google.com/url?q=https://americanbridgepac.us13.list-manage.com/track/click?u%3Dee1bfee563d1c69fe20eff85d%26id%3Db25b3a8964%26e%3D8b8d31f947&amp;source=gmail&amp;ust=1543686119473000&amp;usg=AFQjCNGnmi1IYAYHUuTfolUGQuZE8y0Cjg">SenatorSoundbite.com</a>.&nbsp;</p>
</div>
<div class="clr"></div>
<div class="itemContentFooter">

<span class="itemHits">
Read <b>28</b> times </span>
<div class="clr"></div>
</div>


<div class="clr"></div>
</div>

<div class="itemSocialSharing">

<div class="itemTwitterButton">
<a href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="BayoubuzzSteve">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<div class="itemFacebookButton">
<div id="fb-root"></div>
<script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)) return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script>
<div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
</div>

<div class="itemGooglePlusOneButton">
<div class="g-plusone" data-size="medium"></div>
<script>window.___gcfg={lang:'en-GB'};(function(){var po=document.createElement('script');po.type='text/javascript';po.async=true;po.src='https://apis.google.com/js/platform.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(po,s);})();</script>
</div>
<div class="clr"></div>
</div>
<div class="itemLinks">

<div class="itemCategory">
<span>Published in</span>
<a href="/bb/state-of-louisiana/louisiana-elections">Louisiana elections</a>
</div>

<div class="itemTagsBlock">
<span>Tagged under</span>
<ul class="itemTags">
<li><a href="/issues/itemlist/tag/American%20Bridge">American Bridge</a></li>
<li><a href="/issues/itemlist/tag/Louisiana%20governor">Louisiana governor</a></li>
<li><a href="/issues/john-bel-edwards">John Bel Edwards</a></li>
<li><a href="/issues/itemlist/tag/John%20Kennedy">John Kennedy</a></li>
<li><a href="/issues/itemlist/tag/Senator%20John%20Kennedy">Senator John Kennedy</a></li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorBlock">
<img class="itemAuthorAvatar" src="/media/k2/users/584.jpg" alt="Stephen Sabludowsky" />
<div class="itemAuthorDetails">
<h3 class="itemAuthorName">
<a rel="author" href="/issues/itemlist/user/62-stephensabludowsky">Stephen Sabludowsky</a>
</h3>
<p><p><a href="https://plus.google.com/u/0/+StephenSabludowsky/posts">https://plus.google.com/u/0/+StephenSabludowsky/posts</a></p>
<div class="g-person" data-href="//plus.google.com/113054450087898597578" data-rel="author">&nbsp;</div></p>
<span class="itemAuthorUrl"><i class="icon-globe"></i> <a rel="me" href="http://www.bayoubuzz.com/media/k2/users/584.jpg" target="_blank">www.bayoubuzz.com/media/k2/users/584.jpg</a></span>
<div class="clr"></div>

<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorLatest">
<h3>Latest from Stephen Sabludowsky</h3>
<ul>
<li class="even">
<a href="/bb/state-of-louisiana/louisiana-elections/item/1063675-kennedy-if-runs-leads-edwards-trump-s-favorables-skyrocket-in-pinsonat-s-louisiana-poll">Kennedy, if runs, leads Edwards; Trump’s favorables skyrocket in Pinsonat’s Louisiana poll</a>
</li>
<li class="odd">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063674-trump-says-everybody-knew-about-trump-tower-moscow-really">Trump says everybody knew about Trump Tower Moscow; Really?</a>
</li>
<li class="even">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063669-merry-black-monday-from-general-motors-but-trump-it-s-mueller-time">Merry Black Monday from General Motors, but Trump, it's Mueller Time</a>
</li>
<li class="odd">
<a href="/bb/new-orleans-louisiana/new-orleans-news/item/1063668-get-holiday-punched-wednesday-at-politics-with-a-punch-in-new-orleans">Get Holiday Punched, Wednesday at Politics with a Punch in New Orleans</a>
</li>
<li class="even">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063666-president-trump-pokes-justice-roberts-on-judicial-bias">President Trump pokes Justice Roberts on judicial bias</a>
</li>
</ul>
<div class="clr"></div>
</div>

<div class="itemRelated">
<h3>Related items</h3>
<ul>
<li class="even">
<a class="itemRelTitle" href="/bb/state-of-louisiana/louisiana-elections/item/1063675-kennedy-if-runs-leads-edwards-trump-s-favorables-skyrocket-in-pinsonat-s-louisiana-poll">Kennedy, if runs, leads Edwards; Trump’s favorables skyrocket in Pinsonat’s Louisiana poll</a>
</li>
<li class="odd">
<a class="itemRelTitle" href="/bb/state-of-louisiana/louisiana-elections/item/1063663-crouere-john-kennedy-will-be-louisiana-s-next-governor-if-he-runs">Crouere: John Kennedy will be Louisiana&#039;s next governor, if he runs</a>
</li>
<li class="even">
<a class="itemRelTitle" href="/bb/state-of-louisiana/item/1063628-major-opening-of-i-49-in-louisiana-governor-edwards-leaders-celebrate">Major opening of I-49 in Louisiana, Governor Edwards, leaders celebrate</a>
</li>
<li class="odd">
<a class="itemRelTitle" href="/bb/item/1063617-louisiana-assets-being-deployed-to-aid-hurricane-michael-relief">Louisiana assets being deployed to aid Hurricane Michael relief</a>
</li>
<li class="even">
<a class="itemRelTitle" href="/bb/donald-trump-news-today/donald-trump-news/item/1063609-the-sen-john-kennedy-brett-kavanaugh-testimony-100-missed-opportunity">The Sen. John Kennedy--Brett Kavanaugh testimony, 100% missed opportunity</a>
</li>
<li class="clr"></li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>

<div class="itemNavigation">
<span class="itemNavigationTitle">More in this category:</span>
<a class="itemPrevious" href="/bb/state-of-louisiana/louisiana-elections/item/1063675-kennedy-if-runs-leads-edwards-trump-s-favorables-skyrocket-in-pinsonat-s-louisiana-poll">&laquo; Kennedy, if runs, leads Edwards; Trump’s favorables skyrocket in Pinsonat’s Louisiana poll</a>
</div>


<div class="itemBackToTop">
<a class="k2Anchor" href="/bb/state-of-louisiana/louisiana-elections/item/1063678-john-kennedy-all-mouth-but-no-feat-louisiana-governor-run-stab-launches#startOfPageId1063678">
back to top </a>
</div>
<div class="clr"></div>
</div>


</div>
</div>
</div>
</div>
<div class="rt-sidebar-wrapper rt-grid-3 ">
<div class="rt-sidebar-block">
<div id="rt-sidebar-a">
<div class="rt-social-buttons rt-block">
<div class="clear"></div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:300px;height:600px" data-ad-client="ca-pub-0689976758489378" data-ad-slot="8723776093"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Our Past Webinars</span></h2> </div>
<div class="module-content">
<div class="custom">
<p><a href="https://electionswin.com/products/campaign-fundraising-alexandra-allee-bautsch-the-bautsch-group" style="background: none; margin: 0px; padding: 0px; outline: transparent 0px; height: auto; text-align: left; color: #0066cc; text-transform: none; text-indent: 0px; letter-spacing: normal; overflow: visible; font-family: helvetica neue,Helvetica,Arial,sans-serif; font-size: 13px; font-style: normal; font-variant: normal; font-weight: 400; text-decoration: underline; word-spacing: 0px; white-space: normal; min-width: 0px; orphans: 2;"><img src="/images/allee_5.jpg" alt="allee 5" width="300" height="224" style="background: none; outline: #000000 solid 1px; border: 0px #0066cc; margin-right: auto; margin-left: auto; display: block; cursor: default;" /></a></p>
<p><a href="https://electionswin.com/collections/completed-webinars-how-to-win-your-campaign-and-elections/products/retail-politics-political-climate-analytics"><br /><img src="/images/bern-jim3_2.jpg" alt="bern jim3 2" style="margin-right: auto; margin-left: auto; display: block;" /></a><a href="https://electionswin.com/collections/completed-webinars-how-to-win-your-campaign-and-elections/products/greg-buisson-elections-advertising-and-media"><br /></a></p>
<p><a href="https://electionswin.com/collections/completed-webinars-how-to-win-your-campaign-and-elections/products/greg-buisson-elections-advertising-and-media"><br /><img src="/images/buisson-elections4_1.jpg" alt="buisson elections4 1" style="margin-right: auto; margin-left: auto; display: block;" /></a></p>
<p>&nbsp;</p>
<p>&nbsp;</p>
<p><a href="https://electionswin.com/collections/completed-webinars-how-to-win-your-campaign-and-elections/products/elections-and-campaigns-101-james-farwell-dr-ed-chervenak-judge-david-williams"><img src="/images/cherv-james-williams_3.jpg" alt="cherv james williams 3" style="display: block; margin-left: auto; margin-right: auto;" /></a></p></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Dead Pelican</span></h2> </div>
<div class="module-content">
<div class="custom">
<p><a href="http://thedeadpelican.com"><img src="/images/stories/Optimized-DeadPelican2_1_1.jpg" alt="Optimized-DeadPelican2 1 1" style="display: block; margin-left: auto; margin-right: auto;" /></a></p></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</section>
<section id="rt-bodybottom-surround">
<div class="rt-container">
<div id="rt-mainbottom">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Bayoubuzz, Louisiana, Cloud</span></h2> </div>
<div class="module-content">
<div id="k2ModuleBox770" class="k2TagCloudBlock">
<a href="/issues/itemlist/tag/Bernie Pinsonat" style="font-size:107%" title="21 items tagged with Bernie Pinsonat">
Bernie Pinsonat </a>
<a href="/issues/itemlist/tag/Bobby Jindal" style="font-size:93%" title="12 items tagged with Bobby Jindal">
Bobby Jindal </a>
<a href="/issues/itemlist/tag/Derrick Edwards" style="font-size:109%" title="22 items tagged with Derrick Edwards">
Derrick Edwards </a>
<a href="/issues/itemlist/tag/Donald Trump" style="font-size:120%" title="29 items tagged with Donald Trump">
Donald Trump </a>
<a href="/issues/itemlist/tag/Facebook Live" style="font-size:93%" title="12 items tagged with Facebook Live">
Facebook Live </a>
<a href="/issues/itemlist/tag/fiscal cliff" style="font-size:126%" title="33 items tagged with fiscal cliff">
fiscal cliff </a>
<a href="/issues/itemlist/tag/fiscal session" style="font-size:88%" title="9 items tagged with fiscal session">
fiscal session </a>
<a href="/issues/itemlist/tag/Governor John Bel Edwards" style="font-size:88%" title="9 items tagged with Governor John Bel Edwards">
Governor John Bel Edwards </a>
<a href="/issues/itemlist/tag/Jeff Landry" style="font-size:91%" title="11 items tagged with Jeff Landry">
Jeff Landry </a>
<a href="/issues/itemlist/tag/Jim Brown" style="font-size:94%" title="13 items tagged with Jim Brown">
Jim Brown </a>
<a href="/issues/john-bel-edwards" style="font-size:282%" title="132 items tagged with John Bel Edwards">
John Bel Edwards </a>
<a href="/issues/itemlist/tag/John Kennedy" style="font-size:93%" title="12 items tagged with John Kennedy">
John Kennedy </a>
<a href="/issues/itemlist/tag/John Schroder" style="font-size:109%" title="22 items tagged with John Schroder">
John Schroder </a>
<a href="/issues/itemlist/tag/LABI" style="font-size:101%" title="17 items tagged with LABI">
LABI </a>
<a href="/issues/itemlist/tag/Louisiana" style="font-size:116%" title="27 items tagged with Louisiana">
Louisiana </a>
<a href="/issues/itemlist/tag/Louisiana budget" style="font-size:159%" title="54 items tagged with Louisiana budget">
Louisiana budget </a>
<a href="/issues/itemlist/tag/Louisiana Budget Project" style="font-size:90%" title="10 items tagged with Louisiana Budget Project">
Louisiana Budget Project </a>
<a href="/issues/itemlist/tag/Louisiana business" style="font-size:90%" title="10 items tagged with Louisiana business">
Louisiana business </a>
<a href="/issues/itemlist/tag/Louisiana Democratic Party" style="font-size:91%" title="11 items tagged with Louisiana Democratic Party">
Louisiana Democratic Party </a>
<a href="/issues/itemlist/tag/Louisiana elections" style="font-size:93%" title="12 items tagged with Louisiana elections">
Louisiana elections </a>
<a href="/issues/itemlist/tag/Louisiana governor" style="font-size:271%" title="125 items tagged with Louisiana governor">
Louisiana governor </a>
<a href="/issues/itemlist/tag/Louisiana legislative session" style="font-size:90%" title="10 items tagged with Louisiana legislative session">
Louisiana legislative session </a>
<a href="/issues/louisiana-legislature" style="font-size:300%" title="144 items tagged with Louisiana legislature">
Louisiana legislature </a>
<a href="/issues/itemlist/tag/Louisiana Treasurer" style="font-size:90%" title="10 items tagged with Louisiana Treasurer">
Louisiana Treasurer </a>
<a href="/issues/itemlist/tag/Louisiana Treasurer's race" style="font-size:90%" title="10 items tagged with Louisiana Treasurer&#039;s race">
Louisiana Treasurer's race </a>
<a href="/issues/itemlist/tag/Louisiana Treasurer Race" style="font-size:90%" title="10 items tagged with Louisiana Treasurer Race">
Louisiana Treasurer Race </a>
<a href="/issues/itemlist/tag/neil Riser" style="font-size:90%" title="10 items tagged with neil Riser">
neil Riser </a>
<a href="/issues/new-orleans" style="font-size:91%" title="11 items tagged with New Orleans">
New Orleans </a>
<a href="/issues/itemlist/tag/Rob Maness" style="font-size:94%" title="13 items tagged with Rob Maness">
Rob Maness </a>
<a href="/issues/itemlist/tag/Stephen Waguespack" style="font-size:91%" title="11 items tagged with Stephen Waguespack">
Stephen Waguespack </a>
<div class="clr"></div>
</div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</section>
<footer id="rt-footer-surround">
<div class="rt-container">
<div id="rt-copyright">
<div class="rt-flex-container">
<div class="rt-grid-4 rt-alpha">
<div class="rt-block rt-branding">
<a href="https://www.bayoubuzz.com/" title="Bayoubuzz" class="rt-powered-by"></a>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Privacy</span></h2> </div>
<div class="module-content">
<div class="custom">

<div style="font-family: arial;"><a href="/Bayoubuzzprivacy.pdf"><strong>Privacy Policy</strong></a><span></span></div></div>
</div>
</div>
</div>
</div>
<div class="rt-grid-4">
<div class="rt-copyright-content rt-block">
Designed by RocketTheme	</div>
</div>
<div class="rt-grid-4 rt-omega">
<div class="clear"></div>
<div class="rt-block">
<a href="#" id="gantry-totop" rel="nofollow">Top</a>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</footer>
<div id="rt-debug">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class='mod_ijoomlazone' id='ijoomlazone727'><div class='adg_row'><div class='adg_cell'></div></div></div> </div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</body>
</html>
