<!doctype html>
<html prefix="og: http://ogp.me/ns#" xml:lang="en-gb" lang="en-gb">
<head>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KTNXD4L');</script>

<script src="//widget.manychat.com/90206201070.js" async="async">
</script>
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<base href="https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-legislature/item/1063357-louisiana-democrats-others-on-full-blast-to-stop-gop-house-cuts-in-budget" />
<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<meta name="keywords" content="Louisiana Democratic Party,Louisiana republicans,Louisiana governor,John Bel Edwards,Louisiana hospitals" />
<meta name="title" content="Louisiana Democrats, others on full blast to stop GOP House cuts in budget" />
<meta name="author" content="Media Sources" />
<meta property="og:url" content="https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-legislature/item/1063357-louisiana-democrats-others-on-full-blast-to-stop-gop-house-cuts-in-budget" />
<meta property="og:title" content="Louisiana Democrats, others on full blast to stop GOP House cuts in budget" />
<meta property="og:type" content="article" />
<meta property="og:description" content="Louisiana Democrats, others on full blast to stop GOP House cuts in budget" />
<meta name="description" content="Louisiana Democrats, others on full blast to stop GOP House cuts in budget" />
<meta name="generator" content="Joomla! - Open Source Content Management" />
<title>Louisiana Democrats, others on full blast to stop GOP House cuts in budget</title>
<link href="https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-legislature/item/1063357-louisiana-democrats-others-on-full-blast-to-stop-gop-house-cuts-in-budget" rel="canonical" />
<link href="https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-legislature/item/1063357-louisiana-democrats-others-on-full-blast-to-stop-gop-house-cuts-in-budget/amp" rel="amphtml" />
<link href="/templates/rt_tessellate/favicon.ico" rel="shortcut icon" type="image/vnd.microsoft.icon" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_0.css" />
<link href="https://cdnjs.cloudflare.com/ajax/libs/magnific-popup.js/1.1.0/magnific-popup.min.css" rel="stylesheet" type="text/css" />
<link href="https://cdnjs.cloudflare.com/ajax/libs/simple-line-icons/2.4.1/css/simple-line-icons.min.css" rel="stylesheet" type="text/css" />
<link href="/components/com_k2/css/k2.css?v=2.8.0" rel="stylesheet" type="text/css" />
<link href="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9/themes/base/jquery-ui.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_1.css" />
<link href="/modules/mod_latestnewsenhanced/styles/common_styles-min.css" rel="stylesheet" type="text/css" />
<link href="https://www.bayoubuzz.com/plugins/content/pdf_embed/assets/css/style.css" rel="stylesheet" type="text/css" />
<link href="/media/yendifvideoshare/assets/site/css/yendifvideoshare.css?v=1.2.6" rel="stylesheet" type="text/css" media="screen" />
<link href="/media/yendifvideoshare/player/yendifplayer.css?v=1.2.6" rel="stylesheet" type="text/css" media="screen" />
<link href="/plugins/system/rokbox/assets/styles/rokbox.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_2.css" />
<link href="https://www.bayoubuzz.com/media/editors/arkeditor/css/squeezebox.css" rel="stylesheet" type="text/css" />
<link href="https://www.bayoubuzz.com/modules/mod_ijoomla_adagency_zone/tmpl/mod_ijoomlazone.css" rel="stylesheet" type="text/css" />
<link rel="stylesheet" type="text/css" href="/media/plg_jchoptimize/cache/297c052a32d1bdc5713870532f71eb9c_3.css" />
<script type="application/json" class="joomla-script-options new">{"csrf.token":"48b7d1322a58b23bc92cce1804d92f2d","system.paths":{"root":"","base":""}}</script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/1ac72fc2519e54bb6c9d03eb6ca3663b_0.js"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jquery/1.8/jquery.min.js" type="text/javascript"></script>
<script src="/plugins/system/jqueryeasy/jquerynoconflict.js" type="text/javascript"></script>
<script src="https://ajax.googleapis.com/ajax/libs/jqueryui/1.9/jquery-ui.min.js" type="text/javascript"></script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/1ac72fc2519e54bb6c9d03eb6ca3663b_1.js"></script>
<script src="https://cdnjs.cloudflare.com/ajax/libs/magnific-popup.js/1.1.0/jquery.magnific-popup.min.js" type="text/javascript"></script>
<script src="/media/k2/assets/js/k2.frontend.js?v=2.8.0&amp;sitepath=/" type="text/javascript"></script>
<script src="/media/yendifvideoshare/player/yendifplayer.js?v=1.2.6" type="text/javascript"></script>
<script src="/plugins/system/rokbox/assets/js/rokbox.js" type="text/javascript"></script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/1ac72fc2519e54bb6c9d03eb6ca3663b_2.js"></script>
<script src="/modules/mod_roknavmenu/themes/default/js/rokmediaqueries.js" type="text/javascript"></script>
<script src="/modules/mod_roknavmenu/themes/default/js/sidemenu.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/media/editors/arkeditor/js/jquery.easing.min.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/media/editors/arkeditor/js/squeezebox.min.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/modules/mod_ijoomla_adagency_zone/includes/helper.js" type="text/javascript"></script>
<script src="https://www.bayoubuzz.com/components/com_adagency/includes/js/domready.js" type="text/javascript"></script>
<script type="application/javascript" src="/media/plg_jchoptimize/cache/1ac72fc2519e54bb6c9d03eb6ca3663b_3.js"></script>
<script type="text/javascript">
yendifplayer.config = {"autoplay":0,"analytics":"","autoplaylist":1,"can_skip_adverts":1,"controlbar":1,"currenttime":1,"download":0,"duration":1,"embed":1,"engine":"html5","fullscreen":1,"keyboard":1,"license":"","logo":"","loop":0,"playbtn":1,"playpause":1,"progress":1,"ratio":"1.0000","share":1,"show_adverts_timeframe":1,"show_skip_adverts_on":5,"theme":"black","volume":0.5,"volumebtn":1,"responsive":1,"playlistWidth":750,"playlistHeight":450,"playlistPosition":"right","origin":"https:\/\/www.bayoubuzz.com\/"};if (typeof RokBoxSettings == 'undefined') RokBoxSettings = {pc: '100'};window.addEvent('domready', function(){
            this.RENDERER = 'canvas';
            if (typeof this.MESH != 'undefined'){
                this.MESH.ambient = '#08162A';
                this.MESH.diffuse = '#3068D3';
            }
            if (typeof this.LIGHT != 'undefined'){
                this.LIGHT.ambient = '#08162A';
                this.LIGHT.diffuse = '#3068D3';
            }
        });		(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
		(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
		m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
		})(window,document,'script','//www.google-analytics.com/analytics.js','__gaTracker');
		__gaTracker('create', '', 'auto');
		__gaTracker('send', 'pageview');
	(function()
				{
					if(typeof jQuery == 'undefined')
						return;
					
					jQuery(function($)
					{
						if($.fn.squeezeBox)
						{
							$( 'a.modal' ).squeezeBox({ parse: 'rel' });
				
							$( 'img.modal' ).each( function( i, el )
							{
								$(el).squeezeBox({
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							})
						}
						else if(typeof(SqueezeBox) !== 'undefined')
						{
							$( 'img.modal' ).each( function( i, el )
							{
								SqueezeBox.assign( el, 
								{
									handler: 'image',
									url: $( el ).attr( 'src' )
								});
							});
						}
						
						function jModalClose() 
						{
							if(typeof(SqueezeBox) == 'object')
								SqueezeBox.close();
							else
								ARK.squeezeBox.close();
						}
					
					});
				})();jQuery(function($){ $(".hasTooltip").tooltip({"html": true,"container": "body"}); });
	</script>
<link href="http://feeds.feedburner.com/bayoubuzz/BnFN" rel="alternate" type="application/rss+xml" title="Latest Buzz" />
<link href="http://feeds.feedburner.com/bayoubuzz/QPkg" rel="alternate" type="application/rss+xml" title="News" />
<link href="http://feeds.feedburner.com/bayoubuzz/GTum" rel="alternate" type="application/rss+xml" title="Buzz" />
<link href="http://feeds.feedburner.com/TrumpArticles" rel="alternate" type="application/rss+xml" title="Trump articles" />
<link href="http://feeds.feedburner.com//KGuc" rel="alternate" type="application/rss+xml" title="Louisiana news" />
<link href="http://feeds.feedburner.com/DonaldTrumpLatestNews" rel="alternate" type="application/atom+xml" title="Donald Trump Latest News" />
<link href="http://feeds.feedburner.com/bayoubuzz/oxlh" rel="alternate" type="application/atom+xml" title="New Orleans News" />
<link href="http://feeds.feedburner.com/StateOfLouisiana" rel="alternate" type="application/atom+xml" title="State of Louisiana" />

<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "WebSite",
                "url": "https://www.bayoubuzz.com",
                "potentialAction": {
                    "@type": "SearchAction",
                    "target": "https://www.bayoubuzz.com/index.php?option=com_search&searchphrase=all&searchword={search_term}",
                    "query-input": "required name=search_term"
                }
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "Organization",
                "url": "https://www.bayoubuzz.com",
                "logo": "https://www.bayoubuzz.com/images/logo-cropped.png"
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "Organization",
                "name": "Bayoubuzz",
                "url": "https://www.bayoubuzz.com",
                "sameAs": [
                  "https://www.facebook.com/Bayoubuzz/",
"https://twitter.com/BayoubuzzSteve",
"https://plus.google.com/+StephenSabludowsky",
"https://www.youtube.com/user/bayoubuzz",
"https://www.linkedin.com/in/steve-sabludowsky-631678/"
                ]
            }
            </script>
<script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "BreadcrumbList",
                "itemListElement": [{
                    "@type": "ListItem",
                    "position": 1,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/",
                        "name": "Home"
                    }
                },{
                    "@type": "ListItem",
                    "position": 2,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb",
                        "name": "BB"
                    }
                },{
                    "@type": "ListItem",
                    "position": 3,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/state-of-louisiana/itemlist",
                        "name": "State of Louisiana"
                    }
                },{
                    "@type": "ListItem",
                    "position": 4,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-legislature",
                        "name": "Louisiana Legislature and Legislation"
                    }
                },{
                    "@type": "ListItem",
                    "position": 5,
                    "item": {
                        "@id":  "https://www.bayoubuzz.com/bb/state-of-louisiana/louisiana-legislature/item/1063357-louisiana-democrats-others-on-full-blast-to-stop-gop-house-cuts-in-budget",
                        "name": "Louisiana Democrats, others on full blast to stop GOP House cuts in budget"
                    }
                }]
            }
            </script>

<script async="async" src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
</head>
<body class="logo-type-custom logo-type-custom demostyle-type-preset4 headermode-type-animated headersurround-type-preset4 mainbody-overlay-light font-family-tessellate font-size-is-xlarge menu-type-dropdownmenu menu-dropdownmenu-position-header-b layout-mode-responsive col12 option-com-k2 menu-louisiana-legislature ">
<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-KTNXD4L"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

<script src="//widget.manychat.com/90206201070.js" async="async">
</script>
<div id="rt-page-surround">
<header id="rt-header-surround">
<div id="rt-fss-container" class="rt-fss-container">
<div id="rt-fss-output" class="rt-fss-container"></div>
</div>
<div class="rt-container">
<div id="rt-header">
<div class="rt-flex-container">
<div class="rt-grid-5 rt-alpha">
<div class="rt-logo-block">
<a href="/" id="rt-logo"></a>
</div>
</div>
<div class="rt-grid-7 rt-omega">
<div class="menu-block">
<div class="gf-menu-device-container responsive-type-panel">
</div>
<ul class="gf-menu l1 ">
<li class="item21 ">
<a class="item" href="/">
<span class="menu-item-bg">
Home </span>
</a>
</li>
<li class="item1782 parent active rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb">
<span class="menu-item-bg">
BB </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item1821 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/donald-trump-news-today">
<span class="menu-item-bg">
Donald Trump News Today </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1827 ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-news">
<span class="menu-item-bg">
Donald Trump News </span>
</a>
</li>
<li class="item1828 ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-news-tweets">
<span class="menu-item-bg">
Donald Trump news tweets </span>
</a>
</li>
<li class="item1933 ">
<a class="item" href="/bb/donald-trump-news-today/donald-trump-tags">
<span class="menu-item-bg">
Donald Trump Tags </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1788 ">
<a class="item" href="/bb/jon-bel-edwards">
<span class="menu-item-bg">
John Bel Edwards </span>
</a>
</li>
<li class="item1823 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/new-orleans-louisiana">
<span class="menu-item-bg">
New Orleans Louisiana </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1829 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections">
<span class="menu-item-bg">
New Orleans Elections </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l4">
<li class="item1866 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/michael-bagneris">
<span class="menu-item-bg">
Michael Bagneris </span>
</a>
</li>
<li class="item1867 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/latoya-cantrell">
<span class="menu-item-bg">
LaToya Cantrell </span>
</a>
</li>
<li class="item1868 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/desiree-charbonnet">
<span class="menu-item-bg">
Desiree Charbonnet </span>
</a>
</li>
<li class="item1869 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections/troy-henry">
<span class="menu-item-bg">
Troy Henry </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1830 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-elections-twitter">
<span class="menu-item-bg">
New Orleans elections twitter </span>
</a>
</li>
<li class="item1831 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-news">
<span class="menu-item-bg">
New Orleans News </span>
</a>
</li>
<li class="item1934 ">
<a class="item" href="/bb/new-orleans-louisiana/new-orleans-louisiana-tag">
<span class="menu-item-bg">
New Orleans, Louisiana, Tag </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1824 parent active rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bb/state-of-louisiana">
<span class="menu-item-bg">
State of Louisiana </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown flyout columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l3">
<li class="item1832 active last ">
<a class="item" href="/bb/state-of-louisiana/louisiana-legislature">
<span class="menu-item-bg">
Louisiana Legislature and Legislation </span>
</a>
</li>
<li class="item1833 ">
<a class="item" href="/bb/state-of-louisiana/louisiana-elections">
<span class="menu-item-bg">
Louisiana elections </span>
</a>
</li>
<li class="item1935 ">
<a class="item" href="/bb/state-of-louisiana/louisiana-tags-louisiana-news">
<span class="menu-item-bg">
Louisiana Tags, Louisiana news </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1978 ">
<a class="item" href="/bb/events">
<span class="menu-item-bg">
Events </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item82 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/buzz">
<span class="menu-item-bg">
Buzz </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
</div>
</li>
<li class="item758 ">
<a class="item" href="/rss">
<span class="menu-item-bg">
RSS </span>
</a>
</li>
<li class="item880 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/bayoubuzz-videos">
<span class="menu-item-bg">
Bayoubuzz videos </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item1995 ">
<a class="item" href="/bayoubuzz-videos/louisiana-legislature-videos">
<span class="menu-item-bg">
Louisiana Legislature 2018 Videos </span>
</a>
</li>
</ul>
</div>
</div>
</li>
<li class="item1509 ">
<a class="item" href="/subscribe">
<span class="menu-item-bg">
Newsletter </span>
</a>
</li>
<li class="item1838 parent rt-dropdown-right-large rt-dropdown-right-desktop rt-dropdown-right-tablet">
<a class="item" href="/issues">
<span class="menu-item-bg">
Issues </span>
</a>
<span class="dropdown-spacer"></span>
<div class="dropdown columns-1 " style="width:180px;">
<div class="column col1" style="width:180px;">
<ul class="l2">
<li class="item1836 ">
<a class="item" href="/issues/confederate-monuments">
<span class="menu-item-bg">
Confederate monuments </span>
</a>
</li>
<li class="item1835 ">
<a class="item" href="/issues/john-bel-edwards">
<span class="menu-item-bg">
John Bel Edwards </span>
</a>
</li>
<li class="item1826 ">
<a class="item" href="/issues/new-orleans">
<span class="menu-item-bg">
New Orleans </span>
</a>
</li>
<li class="item1834 ">
<a class="item" href="/issues/mitch-landrieu">
<span class="menu-item-bg">
Mitch Landrieu </span>
</a>
</li>
<li class="item1789 ">
<a class="item" href="/issues/louisiana-legislature">
<span class="menu-item-bg">
Louisiana legislature </span>
</a>
</li>
 </ul>
</div>
</div>
</li>
<li class="item1865 grouped ">
<a class="item" href="/forums">
<span class="menu-item-bg">
Forums </span>
</a>
</li>
<li class="item1930 ">
<a class="item" href="/tag">
<span class="menu-item-bg">
Tag </span>
</a>
</li>
<li class="item1942 ">
<a class="item" href="/feeds">
<span class="menu-item-bg">
Feeds </span>
</a>
</li>
</ul> <div class="clear"></div>
</div>
<div class="clear"></div>
</div>
<div class="clear"></div>
</div>
</div>
<div id="rt-drawer">
<div class="rt-flex-container">
<div class="clear"></div>
</div>
</div>
<div id="rt-top">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>

<ins class="adsbygoogle" style="display:inline-block;width:728px;height:90px" data-ad-client="ca-pub-0689976758489378" data-ad-slot="4004609422"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
<div id="rt-breadcrumbs">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<ul class="breadcrumb">
<li>
You are here: &#160;
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/" class="pathway"><span>Home</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="1">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb" class="pathway"><span>BB</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="2">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb/state-of-louisiana/itemlist" class="pathway"><span>State of Louisiana</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="3">
</li>
<li itemscope itemtype="https://schema.org/ListItem">
<a href="/bb/state-of-louisiana/louisiana-legislature" class="pathway"><span>Louisiana Legislature and Legislation</span></a>
<span class="divider">
<img src="/media/system/images/arrow.png" alt="" /> </span>
<meta content="4">
</li>
<li itemscope itemtype="https://schema.org/ListItem" class="active">
<span>
Louisiana Democrats, others on full blast to stop GOP House cuts in budget </span>
<meta content="5">
</li>
</ul>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</header>
<section id="rt-mainbody-surround">
<div class="rt-container">
<div id="rt-main" class="mb9-sa3">
<div class="rt-flex-container">
<div class="rt-mainbody-wrapper rt-grid-9 ">
<div class="rt-component-block rt-block">
<div id="rt-mainbody">
<div class="component-content">

<span id="startOfPageId1063357"></span>
<div id="k2Container" class="itemView">


<div class="itemHeader">

<span class="itemDateCreated">
Wednesday, 18 April 2018 14:59	</span>

<h1 class="itemTitle">
Louisiana Democrats, others on full blast to stop GOP House cuts in budget
</h1>

<span class="itemAuthor">
<a rel="author" href="/issues/itemlist/user/230-mediasources">Media Sources</a>
</span>
</div>


<div class="itemToolbar">
<ul>

<li>
<span class="itemTextResizerTitle">font size</span>
<a href="#" id="fontDecrease">
<span>decrease font size</span>
</a>
<a href="#" id="fontIncrease">
<span>increase font size</span>
</a>
</li>

<li>
<a class="itemPrintLink" rel="nofollow" href="/bb/state-of-louisiana/louisiana-legislature/item/1063357-louisiana-democrats-others-on-full-blast-to-stop-gop-house-cuts-in-budget?tmpl=component&amp;print=1" onclick="window.open(this.href,'printWindow','width=900,height=600,location=no,menubar=no,resizable=yes,scrollbars=yes'); return false;">
<span>Print</span>
</a>
</li>

<li>
<a class="itemEmailLink" rel="nofollow" href="/component/mailto/?tmpl=component&amp;template=rt_tessellate&amp;link=cf6fe164e497a0568776cf71da4724ba006d45db" onclick="window.open(this.href,'emailWindow','width=400,height=350,location=no,menubar=no,resizable=no,scrollbars=no'); return false;">
<span>Email</span>
</a>
</li>
</ul>
<div class="clr"></div>
</div>

<div class="itemRatingBlock">
<span>Rate this item</span>
<div class="itemRatingForm">
<ul class="itemRatingList">
<li class="itemCurrentRating" id="itemCurrentRating1063357" style="width:0%;"></li>
<li><a href="#" data-id="1063357" title="1 star out of 5" class="one-star">1</a></li>
<li><a href="#" data-id="1063357" title="2 stars out of 5" class="two-stars">2</a></li>
<li><a href="#" data-id="1063357" title="3 stars out of 5" class="three-stars">3</a></li>
<li><a href="#" data-id="1063357" title="4 stars out of 5" class="four-stars">4</a></li>
<li><a href="#" data-id="1063357" title="5 stars out of 5" class="five-stars">5</a></li>
</ul>
<div id="itemRatingLog1063357" class="itemRatingLog">(0 votes)</div>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>
<div class="itemBody">



<div class="itemIntroText">
<p><img src="/images/cuts-coming-capitol.jpg" alt="cuts coming capitol" style="float: left;" />Democrats and those wanting to halt the prospects of drastic cuts are on a full court press. Today, email boxes are flooded by organizations to say no to the Republican Louisiana House of Representative budget for next year. Below are a selection of some of the emails:</p>
</div>

<div class="itemFullText">
<p>&nbsp;</p>
<p><strong><span data-term="goog_2128393999">TOMORROW</span></strong>,&nbsp;<span data-term="goog_2128394000">April 19</span>, the Louisiana House of Representatives will debate House Bill 1, the 2018-2019 state budget. A vote to approve the budget in its current form is a rubber stamp on a document that cuts $648 million. Most of the cuts would come from the state's health care system, including hospitals, doctors, and providers who serve the health care needs of our children, elderly, and people with disabilities. &nbsp;</p>
<p>Several of Louisiana's public-private safety net hospitals have already notified the state that the budget signals a breach in contract and they won't be able to continue paying their employees or offering health care services if the cuts go into effect as proposed.</p>
<p>Yesterday, the chancellor of LSU's medical school in New Orleans pleaded with the House of Representatives to hold off on passing the budget until they can meet in a special session to approve revenue measures. In the words of Dr. Larry Hollier:&nbsp;<strong>"I just don't have enough programs to cut to achieve this. And it's not just that we'd lose the schools but over 1 million patients we treat. Please, please help us."</strong></p>
<p>We need your help to stop the budget before it leaves the House of Representatives.&nbsp;<a href="http://r20.rs6.net/tn.jsp?f=001qy-VxlkvFk-ktEOoz7SO2RxaHP5LqUoPXlhpl8Z6jHOoPqQIANJphsUgBwWSjMIKFsSFfLQq0wAV9ny4XLT-0CYDBF_yfnd5H6oOkgNGyAcnXQTnSmx8VnxG0wGBFgaB_TWzZbOIxrCOjLY8kIRnnmHbWYUVs6zCROmoWRNGjeJ8XzYe_5zQaRtC4IB8W2ojCa4MJjdShKrmzPmxU6sVcQ==&amp;c=Zd9Ii5R4snhc0KjwjP6jV4YZfQFpB-oTU27ZwpwIeMdf9l26eJzDoA==&amp;ch=bvmPfJYTlA-wUbd1CXsOW-PBYmbXukYS6VtYXEh2V7ESwcMFMtyFKA==" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://r20.rs6.net/tn.jsp?f%3D001qy-VxlkvFk-ktEOoz7SO2RxaHP5LqUoPXlhpl8Z6jHOoPqQIANJphsUgBwWSjMIKFsSFfLQq0wAV9ny4XLT-0CYDBF_yfnd5H6oOkgNGyAcnXQTnSmx8VnxG0wGBFgaB_TWzZbOIxrCOjLY8kIRnnmHbWYUVs6zCROmoWRNGjeJ8XzYe_5zQaRtC4IB8W2ojCa4MJjdShKrmzPmxU6sVcQ%3D%3D%26c%3DZd9Ii5R4snhc0KjwjP6jV4YZfQFpB-oTU27ZwpwIeMdf9l26eJzDoA%3D%3D%26ch%3DbvmPfJYTlA-wUbd1CXsOW-PBYmbXukYS6VtYXEh2V7ESwcMFMtyFKA%3D%3D&amp;source=gmail&amp;ust=1524167433645000&amp;usg=AFQjCNHEKA9aYkeT_IDBduOQt9pvYDyXWA">Find out who your representative is here.</a>&nbsp;Their name is the first name listed when you enter your voting address.&nbsp;</p>
<p><strong>Call the House switchboard at 225-342-6945&nbsp;and leave a message for your House member. All you have to say when you call is:</strong></p>
<p><em>Hi, my name is _____________ and I live in ___________, Louisiana. I'm calling to ask Rep. ____________ to vote NO on the budget bill, HB 1. Please end the regular session early and go into special session. Pass a budget WITH revenue solutions so that our health care systems can continue to serve Louisiana families.&nbsp;</em></p>

<div id="lnee_739" class="lnee newslist vertical">
<ul class="latestnews-items">
<li class="latestnews-item id-1063352 catid-380">
<div class="news odd head_left">
<div class="innernews">
<div class="newshead picturetype">
<div class="picture">
<div class="innerpicture">
<a href="/bb/state-of-louisiana/louisiana-legislature/item/1063352-lbp-s-jan-moller-explains-why-louisiana-medicaid-expansion-is-economic-development-boom" class="hasTooltip" title="LBP'S Jan Moller explains why Louisiana Medicaid Expansion is economic development boom"> <img alt="LBP'S Jan Moller explains why Louisiana Medicaid Expansion is economic development boom" src="/images/rocket/thumbnails/lnee/thumb_739_1063352.jpg" /> </a>
</div>
</div>
</div>
<div class="newsinfo">
<h4 class="newstitle">
<a href="/bb/state-of-louisiana/louisiana-legislature/item/1063352-lbp-s-jan-moller-explains-why-louisiana-medicaid-expansion-is-economic-development-boom" class="hasTooltip" title="LBP'S Jan Moller explains why Louisiana Medicaid Expansion is economic development boom"> <span>LBP'S Jan Moller explains why Louisiana Medicaid Expansion is economic development boom</span>
</a>
</h4>
<div class="newsintro">
LBP'S Jon Moller explains why Louisiana Medicaid Expansion is economic development boom </div>
</div>
</div>
</div>
</li>
<li class="latestnews-item id-1063351 catid-380">
<div class="news even head_left">
<div class="innernews">
<div class="newshead picturetype">
<div class="picture">
<div class="innerpicture">
<a href="/bb/state-of-louisiana/louisiana-legislature/item/1063351-gov-edwards-slams-house-appropriations-for-budget-vote-lagop-chair-questions-cliff" class="hasTooltip" title="Gov. Edwards slams House Appropriations for budget vote; LAGOP chair questions cliff"> <img alt="Gov. Edwards slams House Appropriations for budget vote; LAGOP chair questions cliff" src="/images/rocket/thumbnails/lnee/thumb_739_1063351.jpg" /> </a>
</div>
</div>
</div>
<div class="newsinfo">
<h4 class="newstitle">
<a href="/bb/state-of-louisiana/louisiana-legislature/item/1063351-gov-edwards-slams-house-appropriations-for-budget-vote-lagop-chair-questions-cliff" class="hasTooltip" title="Gov. Edwards slams House Appropriations for budget vote; LAGOP chair questions cliff"> <span>Gov. Edwards slams House Appropriations for budget vote; LAGOP chair questions cliff</span>
</a>
</h4>
<div class="newsintro">
Gov. Edwards slams House Appropriations for budget vote; LAGOP chair Louis Gurvich questions cliff numbers </div>
</div>
</div>
</div>
</li>
</ul>
</div>

<p>If legislators don't end this regular session early, they could run out of time to solve the revenue problem before our hospitals start ending contracts with employees and preparing for the worst. Your voice could help keep our legislature on the right path for the people of our state.&nbsp;<strong>Call today.</strong></p>
<p>Thank you,</p>
<p>Dylan Waguespack</p>
<p>#InvestInLa Campaign</p>
<p>&nbsp;</p> <a class="twitter-timeline" href="https://twitter.com/search?q=%23lalege%20budget" data-widget-id="986702952021753857">Tweets about #lalege budget</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+"://platform.twitter.com/widgets.js";fjs.parentNode.insertBefore(js,fjs);}}(document,"script","twitter-wjs");</script>
<p>LOUISIANA DEMOCRATIC PARTY&nbsp;<br /> There is an important vote in the Louisiana House of Legislators&nbsp;<span data-term="goog_2128394005">tomorrow</span>&nbsp;and we need you to&nbsp;<strong><a href="http://action.lademo.org/page/m/69b4790c/4a524fd6/720ca6aa/60a92abc/1588594679/VEsH/" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://action.lademo.org/page/m/69b4790c/4a524fd6/720ca6aa/60a92abc/1588594679/VEsH/&amp;source=gmail&amp;ust=1524167722075000&amp;usg=AFQjCNGsbDN-Oz26lo2uBc2qZ9iUH3gpgA">call your representative</a></strong>&nbsp;to tell them to vote NO. HB1, authored and pushed by republican leadership, is a budget that doesn’t fund critical services in Louisiana and ignores the impending fiscal cliff. Don’t take our word for it- here is what the House Democratic Caucus leadership had to say about it at a press conference this morning:</p>
<p><strong><span style="text-decoration: underline;">Chair Robert Johnson:</span></strong><br /> <em>Democratic leadership is united and willing to compromise to find a solution.</em></p>
<p><em>HB1 basically decimates hospitals in Louisiana and doesn’t adequately fund public universities and public private partnership hospitals as well as a number of other things and leaves $650 million of cuts. This is an immoral budget.</em></p><p>
<div style="text-align:left;">
<ins class="adsbygoogle" style="display:inline-block;width:336px;height:280px" data-ad-client="ca-pub-7741304783035041" data-ad-type="text_image" data-color-border="FFFFFF" data-color-bg="FFFFFF" data-color-link="0088CC" data-color-text="555555" data-color-url="AAAAAA"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div></p>
<p><em>House leadership is echoing that we don’t have a revenue issue and a real deficit in Louisiana. This deficit is real and threatens hospital closures, the developmentally disabled, nursing home patients, and students going to universities that aren’t fully funded.</em></p>
<p><strong><span style="text-decoration: underline;">Representative Pat Smith:</span></strong><br /> <em>The bill is a travesty and injustice. It does ill will to the most vulnerable people in our state.</em></p>
<p><strong><span style="text-decoration: underline;">Representative Sam Jenkins Jr.:</span></strong><br /> <em>This budget doesn’t reflect the values that we as Democrats hold.&nbsp;</em><strong><em>It’s unkind, unconscionable and unrealistic.</em></strong><em>&nbsp;It’s unconscionable because it ignores the needs of the elderly, the sick, and the disabled. It’s unrealistic because our republican friends across the aisle continue to ignore the fact that we are approximately 600 million dollars short of funding the basic services we need in this state.</em></p>
<p><em>Yes, TOPS is important- we all recognize that. But what are we doing by trying to hold our best and our brightest here by giving them a scholarship and they’re going to schools where classrooms are crowded, technology is outdated, we’re having difficulty paying and retaining the faculty and teachers?</em></p>
<p><em>This is a disservice that we should not continue.</em></p>
<p><strong><span style="text-decoration: underline;">Speaker Pro Tempore Walt Leger:</span></strong><br /> <em>Obligation. What is the obligation that the&nbsp;</em><em>legislature</em><em>&nbsp;has to the people of Louisiana?</em></p>
<p><em>With the cuts proposed by republicans, $650 million of cuts remain, the vast majority in the medical school budget… how will our economy survive if billions of dollars of healthcare spending doesn’t happen because we don’t have healthcare professionals?</em></p>
<p><em>Current budget doesn’t restore funding to medical higher education.</em></p>
<p><em>We are getting emails from colleges and medical professionals asking for us to not pass this budget.</em></p>
<p><strong><a href="http://action.lademo.org/page/m/69b4790c/4a524fd6/720ca6aa/60a92abc/1588594679/VEsF/" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://action.lademo.org/page/m/69b4790c/4a524fd6/720ca6aa/60a92abc/1588594679/VEsF/&amp;source=gmail&amp;ust=1524167722075000&amp;usg=AFQjCNHz4rQv-2yX6K57dJSuB5D3lLz4Tg">CALL YOUR REPRESENTATIVE TODAY TO TELL THEM TO VOTE NO&nbsp;<span data-term="goog_2128394006">TOMORROW</span>ON HB1!</a></strong>&nbsp;The future of our state depends on it.</p>
<p>This is worth fighting for,<br /> Stephen Handwerk<br /> Executive Director</p>
<p>FROM LOUISIANA BUDGET PROJECT</p>
<p><strong>Medical school leaders urge budget delay </strong>Chancellors from LSU's two medical schools &nbsp; pleaded with lawmakers <span data-term="goog_2128394007">on Tuesday</span><br />&nbsp; to hold off on passing a 2019 state budget until the Legislature &nbsp; has another opportunity to consider additional revenue measures in a second<br />&nbsp; special session. Without additional tax revenue, the current $648 million &nbsp; shortfall would fall most heavily on the state's health care system - causing<br />&nbsp; cuts deep enough to threaten the existence of LSU's graduate medical &nbsp; education programs. While Gov. John Bel Edwards has been vocal about his<br />&nbsp; support to call a special session to consider tax increases to close the &nbsp; budget gap, there is far from unanimity at the Capitol, especially in the<br />&nbsp; House. <br /><a href="http://r20.rs6.net/tn.jsp?f=001hb7xZyDaXWePgYUVXYIg891HkqoOCuhFx2ZXVsoGg0MMAnC8quDioodQuk7ga8FJwrXyT5h2MQRcX6q9HBDpD9qmFUSEcN2jkhZAOhbbwkEm5vfcEUGjd9_iD-tkneoZR4VfQmcpa3GYQXSxAnMvP-pn_2wDlfqtlfhVRM7mfQ84dJ0Gi9SUSKe_fJANB8nOjg6pjKlGqiM7Zq1FzjG3Zg==&amp;c=pUL7tnY1qTPVy47Mua24R-KU15CVt25crmYS_idiQ5l4gS8tCijU3Q==&amp;ch=Fl3bjMqJgSOrzTsfOhjIXh-CDn8lFpUjuWZJbGJx6mslOvhCPfZzaw==" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://r20.rs6.net/tn.jsp?f%3D001hb7xZyDaXWePgYUVXYIg891HkqoOCuhFx2ZXVsoGg0MMAnC8quDioodQuk7ga8FJwrXyT5h2MQRcX6q9HBDpD9qmFUSEcN2jkhZAOhbbwkEm5vfcEUGjd9_iD-tkneoZR4VfQmcpa3GYQXSxAnMvP-pn_2wDlfqtlfhVRM7mfQ84dJ0Gi9SUSKe_fJANB8nOjg6pjKlGqiM7Zq1FzjG3Zg%3D%3D%26c%3DpUL7tnY1qTPVy47Mua24R-KU15CVt25crmYS_idiQ5l4gS8tCijU3Q%3D%3D%26ch%3DFl3bjMqJgSOrzTsfOhjIXh-CDn8lFpUjuWZJbGJx6mslOvhCPfZzaw%3D%3D&amp;source=gmail&amp;ust=1524167722116000&amp;usg=AFQjCNGNSl5spKv5FtnLZt9Tb1X91btcrQ">The AP's &nbsp; Melinda Deslatte reports</a>:<em>"We need &nbsp; to stop where we are and hit a reset button. We need to not pass this<br />&nbsp; budget," said Ghali, the Shreveport chancellor. The chancellors hope &nbsp; lawmakers hold a special session to consider taxes to replace some taxes that<br />&nbsp; expire with the start of the new budget year, to close the $648 million &nbsp; budget gap. They said if lawmakers pass the budget with the cuts - even if<br />&nbsp; they plan to later add dollars - it would send a signal to faculty and &nbsp; students that the reductions to graduate medical education and the safety-net<br />&nbsp; hospitals in which students train might actually happen. "If you pass &nbsp; this budget, there's almost a sense of finality," (Larry) Hollier, the<br />&nbsp; New Orleans chancellor, told the Senate Finance Committee.</em>The cuts to the state's public-private &nbsp; "safety net" hospitals would affect medical schools because they &nbsp; rely on the hospitals as labs for graduate medical education and revenue &nbsp; streams from patient treatment.</p>
<p><a href="http://r20.rs6.net/tn.jsp?f=001hb7xZyDaXWePgYUVXYIg891HkqoOCuhFx2ZXVsoGg0MMAnC8quDioodQuk7ga8FJ0aIRcn-5AkCmqyh_khalw0ydoqEQjPfo5T7_yRpbBOCea4cy4XDPVYKL6YlXWSbDLpePpCJ6kEyhCDgeuwft1Sa6XQ-LOp3lPeo9TuByQZuyMjsvDuobIY1-Ai10kpIxVkQSczGv083P2Ogx9XQ10i3HeG4XNJkBfia5pbFSYkHLDzY4EWEwnGmDGTs_UgRT7ietIQG2SCQE-Qk20H5lht0InVOzQ4tHf-WcwRNo2trj9jUkYJmckjnQfZXUCXcI&amp;c=pUL7tnY1qTPVy47Mua24R-KU15CVt25crmYS_idiQ5l4gS8tCijU3Q==&amp;ch=Fl3bjMqJgSOrzTsfOhjIXh-CDn8lFpUjuWZJbGJx6mslOvhCPfZzaw==" data-saferedirecturl="https://www.google.com/url?hl=en&amp;q=http://r20.rs6.net/tn.jsp?f%3D001hb7xZyDaXWePgYUVXYIg891HkqoOCuhFx2ZXVsoGg0MMAnC8quDioodQuk7ga8FJ0aIRcn-5AkCmqyh_khalw0ydoqEQjPfo5T7_yRpbBOCea4cy4XDPVYKL6YlXWSbDLpePpCJ6kEyhCDgeuwft1Sa6XQ-LOp3lPeo9TuByQZuyMjsvDuobIY1-Ai10kpIxVkQSczGv083P2Ogx9XQ10i3HeG4XNJkBfia5pbFSYkHLDzY4EWEwnGmDGTs_UgRT7ietIQG2SCQE-Qk20H5lht0InVOzQ4tHf-WcwRNo2trj9jUkYJmckjnQfZXUCXcI%26c%3DpUL7tnY1qTPVy47Mua24R-KU15CVt25crmYS_idiQ5l4gS8tCijU3Q%3D%3D%26ch%3DFl3bjMqJgSOrzTsfOhjIXh-CDn8lFpUjuWZJbGJx6mslOvhCPfZzaw%3D%3D&amp;source=gmail&amp;ust=1524167722116000&amp;usg=AFQjCNFbUpyIVKXs9gcWjWHyaie_qGe6pw">Greg Hilburn of &nbsp; USA Today Network reports</a>:<em>"Jesus tell me what I'm supposed to &nbsp; cut," Ghali said. "There won't be any schools." Hollier said<br />&nbsp; that even if the Legislature agreed to meet Edwards' &nbsp; request to allocate enough money to keep open the Shreveport and New Orleans<br />&nbsp; hospitals it wouldn't be enough to offset the other closures. "We'd be &nbsp; in financial exigency (bankruptcy)," Hollier said. "I don't have<br />&nbsp; enough programs to cut to achieve this. And it's not just that we'd lose the &nbsp; schools but over 1 million patients we treat. "Please, please help<br />&nbsp; us," he said.&nbsp;</em></p>
<p>&nbsp;</p>
<p><a href="https://twitter.com/search?q=%23lalege%20budget" class="twitter-timeline" data-widget-id="986702952021753857">Tweets about #lalege budget</a></p>
</div>
<div class="clr"></div>
<div class="itemContentFooter">

<span class="itemHits">
Read <b>50</b> times </span>

<span class="itemDateModified">
Last modified on Wednesday, 18 April 2018 15:30 </span>
<div class="clr"></div>
</div>


<div class="clr"></div>
</div>

<div class="itemSocialSharing">

<div class="itemTwitterButton">
<a href="https://twitter.com/share" class="twitter-share-button" data-lang="en-gb" data-via="BayoubuzzSteve">Tweet</a>
<script>!function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0],p=/^http:/.test(d.location)?'http':'https';if(!d.getElementById(id)){js=d.createElement(s);js.id=id;js.src=p+'://platform.twitter.com/widgets.js';fjs.parentNode.insertBefore(js,fjs);}}(document, 'script', 'twitter-wjs');</script>
</div>

<div class="itemFacebookButton">
<div id="fb-root"></div>
<script>(function(d,s,id){var js,fjs=d.getElementsByTagName(s)[0];if(d.getElementById(id)) return;js=d.createElement(s);js.id=id;js.src="//connect.facebook.net/en_GB/sdk.js#xfbml=1&version=v2.5";fjs.parentNode.insertBefore(js,fjs);}(document,'script','facebook-jssdk'));</script>
<div class="fb-like" data-width="200" data-layout="button_count" data-action="like" data-show-faces="false" data-share="false"></div>
</div>

<div class="itemGooglePlusOneButton">
<div class="g-plusone" data-size="medium"></div>
<script>window.___gcfg={lang:'en-GB'};(function(){var po=document.createElement('script');po.type='text/javascript';po.async=true;po.src='https://apis.google.com/js/platform.js';var s=document.getElementsByTagName('script')[0];s.parentNode.insertBefore(po,s);})();</script>
</div>
<div class="clr"></div>
</div>
<div class="itemLinks">

<div class="itemCategory">
<span>Published in</span>
<a href="/bb/state-of-louisiana/louisiana-legislature">Louisiana legislature</a>
</div>

<div class="itemTagsBlock">
<span>Tagged under</span>
<ul class="itemTags">
<li><a href="/issues/itemlist/tag/Louisiana%20Democratic%20Party">Louisiana Democratic Party</a></li>
<li><a href="/issues/itemlist/tag/Louisiana%20republicans">Louisiana republicans</a></li>
<li><a href="/issues/itemlist/tag/Louisiana%20governor">Louisiana governor</a></li>
<li><a href="/issues/john-bel-edwards">John Bel Edwards</a></li>
<li><a href="/issues/itemlist/tag/Louisiana%20hospitals">Louisiana hospitals</a></li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorBlock">
<img class="itemAuthorAvatar" src="https://secure.gravatar.com/avatar/56bc4f03ce09977cfc557acc556b4edb?s=100&amp;default=https%3A%2F%2Fwww.bayoubuzz.com%2Fcomponents%2Fcom_k2%2Fimages%2Fplaceholder%2Fuser.png" alt="Media Sources" />
<div class="itemAuthorDetails">
<h3 class="itemAuthorName">
<a rel="author" href="/issues/itemlist/user/230-mediasources">Media Sources</a>
</h3>
<p><p>BayoubuzzSteve</p></p>
<span class="itemAuthorUrl"><i class="icon-globe"></i> <a rel="me" href="http://www.bayoubuzz.com" target="_blank">www.bayoubuzz.com</a></span>
<div class="clr"></div>

<div class="clr"></div>
</div>
<div class="clr"></div>
</div>

<div class="itemAuthorLatest">
<h3>Latest from Media Sources</h3>
<ul>
<li class="even">
<a href="/bb/donald-trump-news-today/donald-trump-news/item/1063354-transcript-of-the-view-interview-stormy-daniels-attorney-reveal-drawing-of-man">Transcript of The View Interview: Stormy Daniels, attorney reveal drawing of man</a>
</li>
<li class="odd">
<a href="/bb/state-of-louisiana/louisiana-legislature/item/1063352-lbp-s-jan-moller-explains-why-louisiana-medicaid-expansion-is-economic-development-boom">LBP'S Jan Moller explains why Louisiana Medicaid Expansion is economic development boom</a>
</li>
<li class="even">
<a href="/bb/state-of-louisiana/louisiana-legislature/item/1063320-louisiana-black-caucus-slams-lack-of-justice-in-alton-sterling-case">Louisiana Black Caucus slams lack of justice in Alton Sterling case</a>
</li>
<li class="odd">
<a href="/bb/item/1063309-second-amendment-backers-take-aim-at-freedom-of-the-press">Second Amendment backers take aim at Freedom of the Press?</a>
</li>
<li class="even">
<a href="/bb/state-of-louisiana/item/1063307-col-maness-anguished-over-conflict-between-pearl-river-cops-and-military-veteran">Col. Maness anguished over conflict between Pearl River cops and military veteran</a>
</li>
</ul>
<div class="clr"></div>
</div>

<div class="itemRelated">
<h3>Related items</h3>
<ul>
<li class="even">
<a class="itemRelTitle" href="/bb/state-of-louisiana/louisiana-legislature/item/1063352-lbp-s-jan-moller-explains-why-louisiana-medicaid-expansion-is-economic-development-boom">LBP&#039;S Jan Moller explains why Louisiana Medicaid Expansion is economic development boom</a>
</li>
<li class="odd">
<a class="itemRelTitle" href="/bb/state-of-louisiana/louisiana-legislature/item/1063351-gov-edwards-slams-house-appropriations-for-budget-vote-lagop-chair-questions-cliff">Gov. Edwards slams House Appropriations for budget vote; LAGOP chair questions cliff</a>
</li>
<li class="even">
<a class="itemRelTitle" href="/bb/state-of-louisiana/louisiana-legislature/item/1063342-fiscal-cliff-346-less-so-taxes-or-cuts-jan-moller-of-louisiana-budget-project-discusses-today">Fiscal Cliff, $346 less, so taxes or cuts? Jan Moller of Louisiana Budget Project discusses today</a>
</li>
<li class="odd">
<a class="itemRelTitle" href="/bb/state-of-louisiana/louisiana-legislature/item/1063331-did-governor-edwards-blow-great-op-after-peterson-s-2nd-amendment-tweet">Did Governor Edwards blow great op after Peterson&#039;s 2nd amendment tweet?</a>
</li>
<li class="even">
<a class="itemRelTitle" href="/bb/state-of-louisiana/louisiana-legislature/item/1063325-louisiana-legislative-shootout-or-snooze-out-over-guns-equal-pay-minimum-wage">Louisiana legislative shootout or snooze-out over guns, equal pay, minimum wage?</a>
</li>
<li class="clr"></li>
</ul>
<div class="clr"></div>
</div>
<div class="clr"></div>

<div class="itemNavigation">
<span class="itemNavigationTitle">More in this category:</span>
<a class="itemPrevious" href="/bb/state-of-louisiana/louisiana-legislature/item/1063352-lbp-s-jan-moller-explains-why-louisiana-medicaid-expansion-is-economic-development-boom">&laquo; LBP'S Jan Moller explains why Louisiana Medicaid Expansion is economic development boom</a>
</div>



<a name="itemCommentsAnchor" id="itemCommentsAnchor"></a>
<div class="itemComments">
<div class="itemCommentsLoginFirst">Login to post comments</div>
</div>
<div class="itemBackToTop">
<a class="k2Anchor" href="/bb/state-of-louisiana/louisiana-legislature/item/1063357-louisiana-democrats-others-on-full-blast-to-stop-gop-house-cuts-in-budget#startOfPageId1063357">
back to top </a>
</div>
<div class="clr"></div>
</div>


</div>
</div>
</div>
</div>
<div class="rt-sidebar-wrapper rt-grid-3 ">
<div class="rt-sidebar-block">
<div id="rt-sidebar-a">
<div class="rt-social-buttons rt-block">
<div class="clear"></div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Advertisers/Sponsors</span></h2> </div>
<div class="module-content">
<div class='mod_ijoomlazone' id='ijoomlazone725'><div class='adg_row'><div class='adg_cell'></div></div></div> </div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class="custom">
<p><a href="http://www.latter-blum.com"><img src="/images/rocket/latter-blum2.gif" alt="latter-blum2" style="vertical-align: middle; display: block; margin-left: auto; margin-right: auto;" /></a></p></div>
</div>
</div>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Dead Pelican</span></h2> </div>
<div class="module-content">
<div class="custom">
<p><a href="http://thedeadpelican.com"><img src="/images/stories/Optimized-DeadPelican2_1_1.jpg" alt="Optimized-DeadPelican2 1 1" style="display: block; margin-left: auto; margin-right: auto;" /></a></p></div>
</div>
</div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</section>
<section id="rt-bodybottom-surround">
<div class="rt-container">
<div id="rt-mainbottom">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Bayoubuzz, Louisiana, Cloud</span></h2> </div>
<div class="module-content">
<div id="k2ModuleBox770" class="k2TagCloudBlock">
<a href="/issues/itemlist/tag/Angele Davis" style="font-size:97%" title="9 items tagged with Angele Davis">
Angele Davis	</a>
<a href="/issues/itemlist/tag/Baton Rouge" style="font-size:89%" title="6 items tagged with Baton Rouge">
Baton Rouge	</a>
<a href="/issues/itemlist/tag/Bernie Pinsonat" style="font-size:118%" title="17 items tagged with Bernie Pinsonat">
Bernie Pinsonat	</a>
<a href="/issues/itemlist/tag/Bobby Jindal" style="font-size:94%" title="8 items tagged with Bobby Jindal">
Bobby Jindal	</a>
<a href="/issues/itemlist/tag/Derrick Edwards" style="font-size:131%" title="22 items tagged with Derrick Edwards">
Derrick Edwards	</a>
<a href="/issues/itemlist/tag/Donald Trump" style="font-size:120%" title="18 items tagged with Donald Trump">
Donald Trump	</a>
<a href="/issues/itemlist/tag/Facebook Live" style="font-size:99%" title="10 items tagged with Facebook Live">
Facebook Live	</a>
<a href="/issues/itemlist/tag/fiscal cliff" style="font-size:150%" title="29 items tagged with fiscal cliff">
fiscal cliff	</a>
<a href="/issues/itemlist/tag/Jeff Landry" style="font-size:94%" title="8 items tagged with Jeff Landry">
Jeff Landry	</a>
<a href="/issues/itemlist/tag/Jim Brown" style="font-size:94%" title="8 items tagged with Jim Brown">
Jim Brown	</a>
<a href="/issues/john-bel-edwards" style="font-size:300%" title="86 items tagged with John Bel Edwards">
John Bel Edwards	</a>
<a href="/issues/itemlist/tag/John Couvillon" style="font-size:94%" title="8 items tagged with John Couvillon">
John Couvillon	</a>
<a href="/issues/itemlist/tag/John Kennedy" style="font-size:91%" title="7 items tagged with John Kennedy">
John Kennedy	</a>
<a href="/issues/itemlist/tag/John Schroder" style="font-size:131%" title="22 items tagged with John Schroder">
John Schroder	</a>
<a href="/issues/itemlist/tag/LABI" style="font-size:105%" title="12 items tagged with LABI">
LABI	</a>
<a href="/issues/itemlist/tag/Louisiana" style="font-size:123%" title="19 items tagged with Louisiana">
Louisiana	</a>
<a href="/issues/itemlist/tag/Louisiana budget" style="font-size:128%" title="21 items tagged with Louisiana budget">
Louisiana budget	</a>
<a href="/issues/itemlist/tag/Louisiana Democratic Party" style="font-size:97%" title="9 items tagged with Louisiana Democratic Party">
Louisiana Democratic Party	</a>
<a href="/issues/itemlist/tag/Louisiana governor" style="font-size:279%" title="78 items tagged with Louisiana governor">
Louisiana governor	</a>
<a href="/issues/itemlist/tag/Louisiana legislative session" style="font-size:91%" title="7 items tagged with Louisiana legislative session">
Louisiana legislative session	</a>
<a href="/issues/louisiana-legislature" style="font-size:290%" title="82 items tagged with Louisiana legislature">
Louisiana legislature	</a>
<a href="/issues/itemlist/tag/Louisiana politics" style="font-size:89%" title="6 items tagged with Louisiana politics">
Louisiana politics	</a>
<a href="/issues/itemlist/tag/Louisiana Treasurer" style="font-size:99%" title="10 items tagged with Louisiana Treasurer">
Louisiana Treasurer	</a>
<a href="/issues/itemlist/tag/Louisiana Treasurer's race" style="font-size:99%" title="10 items tagged with Louisiana Treasurer&#039;s race">
Louisiana Treasurer's race	</a>
<a href="/issues/itemlist/tag/Louisiana Treasurer Race" style="font-size:99%" title="10 items tagged with Louisiana Treasurer Race">
Louisiana Treasurer Race	</a>
<a href="/issues/itemlist/tag/neil Riser" style="font-size:94%" title="8 items tagged with neil Riser">
neil Riser	</a>
<a href="/issues/new-orleans" style="font-size:99%" title="10 items tagged with New Orleans">
New Orleans	</a>
<a href="/issues/itemlist/tag/Rob Maness" style="font-size:97%" title="9 items tagged with Rob Maness">
Rob Maness	</a>
<a href="/issues/itemlist/tag/Stephen Waguespack" style="font-size:94%" title="8 items tagged with Stephen Waguespack">
Stephen Waguespack	</a>
<a href="/issues/itemlist/tag/Tropical storm Harvey" style="font-size:91%" title="7 items tagged with Tropical storm Harvey">
Tropical storm Harvey	</a>
<div class="clr"></div>
</div>
</div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</section>
<footer id="rt-footer-surround">
<div class="rt-container">
<div id="rt-copyright">
<div class="rt-flex-container">
<div class="rt-grid-4 rt-alpha">
<div class="rt-block rt-branding">
<a href="https://www.bayoubuzz.com/" title="Bayoubuzz" class="rt-powered-by"></a>
</div>
<div class="rt-block ">
<div class="module-surround">
<div class="module-title">
<h2 class="title"><span>Privacy</span></h2> </div>
<div class="module-content">
<div class="custom">

<div style="font-family: arial;"><a href="/Bayoubuzzprivacy.pdf"><strong>Privacy Policy</strong></a><span></span></div></div>
</div>
</div>
</div>
</div>
<div class="rt-grid-4">
<div class="rt-copyright-content rt-block">
Designed by RocketTheme	</div>
</div>
<div class="rt-grid-4 rt-omega">
<div class="clear"></div>
<div class="rt-block">
<a href="#" id="gantry-totop" rel="nofollow">Top</a>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</footer>
<div id="rt-debug">
<div class="rt-flex-container">
<div class="rt-grid-12 rt-alpha rt-omega">
<div class="rt-block ">
<div class="module-surround">
<div class="module-content">
<div class='mod_ijoomlazone' id='ijoomlazone727'><div class='adg_row'><div class='adg_cell'></div></div></div> </div>
</div>
</div>
</div>
<div class="clear"></div>
</div>
</div>
</div>
</body>
</html>
